Wireless USB keyboard will not pair on RPi3 with 2017.03-1

Hi,
This week my Rii 8i stopped connecting to the dongle, since updating to 2017.03-1. I tested the device on 3 windows pc’s and it paired immedeately!
Please help!

Logs?
https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

Http://paste.osmc.io/bejosuhaco

Nothing too obvious, but you installed the bluetooth streaming service.

Did it work before you installed that?

Not in purpose. There was a extra update yesterday, however. I first installed that before uploading the logs.
IT stopped working since the previous update.

Do you use a normal bluetooth dongle or does it come with its own propriatery one?

It has it’s own dongle. As said: it had worked perfectly before.

I think as you wrote “paired” @mcobit thought it is Bluetooth.
But AFAIK this is a 2.4 GHz wireless keyboard which doesn’t require pairing.
I have the same/similar keyboard and it is still working fine.
So I have doubts that it is related to OSMC.
Suggest to check power, try other USB Port and last install another Distribution on the Pi to test if it works there.

Actually one more thing to check. Is the touch pad (mouse) working?

No, it won’t pair at all. The orange led keeps flashing. Therefore no touchpad either.

I tried several USB ports already. And a connection has to be made (Blue led). Using Fn+F1 or powering on White pressing F1 had no effect either. Using dongle and keyboard on a pc gives no problems.

What about Linux PC’s?

The Rii i8 is 2.4ghz based I really doubt that it needs paring.
Anyhow even if it needs paring than that would be independent from OSMC as there is no specific software for that keyboard.
http://www.riitek.com/product/i8.html

Try using a powered USB hub. I bet that the Pi2 isn’t suppling enough power.

I don’t have any.

Normally you would be right, unless the BIOS (if you may speak of that with a Raspberry) als would be altered with the update?
I wonder if there is a sort of “device manager”, so I can see if the dongle is even detected or not… ?

Then the power requirement has been changed all of a sudden? I has worked perfectly for 8 months?

Can be. Also psus degrade.

Plug it in and type dmesg

Let me write it once more, AFAIK neither the Raspberry nor OSMC have any specific driver to pair this keyboard. This is something happening between the dongle and the keyboard automatically.

dmesg | grep usb will show all USB detected devices.

And if you provide the output of dmesg | paste-log than we also can help you to see what might be wrong.