Woofer problem in 5.1 analogic audio equipment

Hello everyone,

My OSMC is on a PI3 B, I’ve connected it with CM106 USB audio device, also I have this device HDMI output,

https://www.amazon.es/HDMI-Decodificador-perfecto-Blue-Ray-reproductor/dp/B06ZYGXMGL/ref=sr_1_8?s=electronics&ie=UTF8&qid=1533769514&sr=1-8&keywords=hdmi+vga+5.1

The problem is that I hardly listen a murmur from the woofer speaker output, I think, I’ve tried every audio configurations and combinations,

CM106 with alsa and pulseaudio
PI HDMI, via HDMI
PI analog
bcm2835 alsa

5.1 + passthrough (DTS, AC3)
5.1 without passthrough
2.0 + passthrough (DTS, AC3)

I’ve turned the woofer channel volume up form aslamixer.

Most of the cases I got 2.0 or 5.0, the sound is fine but woofer never work (of course the speaker is OK).
I also appreciate any comments or feedback.

Thanks.

Hi,

Make sure output configuration is set to best matched.

Thanks Tom.

Thanks for your reply.

I did it with the same results.

On the other hand I installed Libreelec but the woofer behavior is the same and it continued murmuring.

Hi,

Long shot, but it try the numbers to 7.1 and letting the HDMI Decodificador do the processing to 5.1

Thanks Tom.

I just checked on a Pi3+ with my Cmedia USB soundcard. I had to remove pulseaudio and set the soundcard to its U2 (HD) mode, but then everything was fine.

If you can get debug logs, we could have a closer look for you. How to submit a useful support request

Ok,

I try with the Tom_Doyle add but nothing change.

I purged pulseaudio, I configured USB soundcard enabling passthrough options, the sound in good in the 5 first channels and the murmur remains in woofer channel.
This is the full log file.
https://paste.osmc.tv/dotetutuhi

Did you tried the USB Soundcard connected to e.g. your PC to ensure the Hardware is fine?

I have the same problem when I unplug the audio device and I use PI HDMI out, with and without passthrough.

Well eventually It was a hardware problem, I thrown away the CN106 sound card and I used the other device optical output to get 5.1 signal.

Thanks and sorry for all.

1 Like