Wrong depth settings for 3D subtitles


Sorry if this question has already been raised, but I did not find any fix for this on the internet.

I am running OSMC 2019.11-1 on a RPI 3.

When watching a 3D movie (sbs or ou), we can also play 2D subtitles.
When it is properly configured, the RPI sends directly a 3D signals to the TV, and subtitles appears in the middle of the screen.
So far, no problem.

As sometimes it can be difficult to read subtitles when pictures seems to be in front of it (let’s say ‘out’ of the TV), there is a setting called “3D depth for subtitles” that allows to define the depth of subtitles.
It goes from 0 to 10.

Problem is : currently, this setting only “push” subtitles further IN the TV which makes them impossible to read.
In previous versions of OSMC (not sure but maybe 6 months ago or more), this setting was used to “pull” subtitles OUT of the TV which makes more sense as it was in front of the picture.
So it seems at some point in dev, Left and Right images for subtitles were inverted.

Am I missing something ?
Is there another way to set correct depth to 3D subtitles ?

Thank you

As this seems to not be a platform specific issue I’d recommend raising this with Kodi.


OK thank you for your answer.
I was not sure if it was OSMC or KODI related.
I will ask them.