XML File for Window is missing

I haven’t used OSMC before.
I installed OSMC on a raspberry pi 2.
I tried to add a music add-on, I tried grooveshark and mpd.

When I select to run the addon it says “Script Failed”.
The error in the kodi log was “XML File for Window is missing”. I had a look at the mpd error in more detail.
The line failing is:
selectorUI = SelectMPDProfile( ‘select-profile.xml’,addon.getAddonInfo(‘path’), skin)

I am presuming that one of the xml files doesn’t exist or a path is incorrect.

The addon path is “/home/osmc/.kodi/addons/script.mpdc”

osmc@osmc:~$ ls /home/osmc/.kodi/addons/script.mpdc
addon.xml changelog.txt default.py default.py~ default.pyo fanart.jpg icon.png LICENSE.txt README resources

It is using the skin Confluence and I found that there is a file /home/osmc/.kodi/addons/script.mpdc/resources/skins/Confluence/720p/select-profile.xml

I could attempt to debug this further with my weak python skills, but perhaps someone can point me in the right direction? This is just a clean install of OSMC so I’m not sure how anything can be configured incorrectly but I haven’t used it before and I didn’t find a post with the same issue so I’m not sure.

Thanks in advance

The full kodi log contains:

20:16:40 T:1793405984 ERROR: EXCEPTION: XML File for Window is missing
20:16:40 T:1793405984 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<–
Error Type: <type ‘exceptions.RuntimeError’>
Error Contents: XML File for Window is missing
Traceback (most recent call last):
File “/home/osmc/.kodi/addons/script.mpdc/default.py”, line 148, in
selectorUI = SelectMPDProfile( ‘select-profile.xml’,addon.getAddonInfo(‘path’), skin)
RuntimeError: XML File for Window is missing
–>End of Python script error report<–

Most likely this is a bug in the addon - have you contacted the author of the addon and provided them logs ?

Thanks for the response.

I haven’t contacted the authors of the addons. I can try and find out who to contact.
The same thing happened with the first two addons that I tried. I thought it might be something more general.

Ah, turns out I lied. Grooveshark also gave me an error, but a different one. I guess it probably is addon specific.