Yamaha RX-S602 Remote not working, CEC issue?

Vero4K <-- HDMI --> Yamaha receiver RX-S602 <-- HDMI --> Sony w7 TV (2015).

HDMI-CEC is enabled on the TV and the Yamaha and it seems to work partly:

  1. When I turn the TV on, the Yamaha turns on automatically.
  2. When I adjust volume with the TV remote, I can see the OSD indication of the Yamaha that volume is being adjusted.

However, I both the Yamaha and the TV remote have no effect on the Vero (navigating through Kodi or controlling playback). I tried 3 different HDMI cables, also switching them between receiver/Vero4K and receiver/TV.

My goal is to at least get the Yamaha remote working with the Vero4K. I would also like to turn the TV off using the Home button on the OSMC remote but that’s offtopic.

Note that before I had the Yamaha, I had a very old Onkyo receiver, same TV and I could use both the Onkyo and the TV remote with the Vero4K. The issue started since I have the Yamaha.

Log Uploader in OSMC is not working… I get paste.osmc.io/
I tried “copy to SD card” but that doesn’t seem to work either.

Try re-booting and uploading logs.

Usual CEC troubleshooting tips:

  • Try power down everything at the mains for 10 minutes.
  • Are any other devices connected to the TV / AVR? Does removing them help as a temporary test?

This should be possible. The easiest way may be using the keymap editor add-on