You need permission to perform this action


I have a little problem with permission on my external disc…I using Kodi+Deluge+Samba and everythnig works great when I try add a file with Windows on external disc…but for example…when I want add the subtitles in torrent I get:

“you need permission to perform this action”

why is that?

I cant writte anything inside the folders which they are on external disc

Hi Miha, seems that you have red-only access on samba share from OSMC


yes looks like…how can I change that…thanks

My samba config

comment = Backup Folder
path = /media/Filmi
valid users = @users
force group = users
create mask = 0660
directory mask = 0771
read only = no

Now it is worked…I just type next command:

sudo chmod -R 777 /media/Filmi {-- in my case


This command didnt solved a problem…now I have a permission for all old torrents on my external disc…If I download new one, I must put again this command in to work…

Can somebody tell me what I have to do, to get this permisson permanetly

sudo chmod -R 777