YouTube addon stopped working - repeatedly requesting revalidation

Hi my osmc was locked up when I switched on the TV this evening so after much trying to wake it up I had to pull the plug :disappointed:

On restarting when I tried to run the YouTube addon it prompted me to re-verify through Youtube.com/activate Unfortunately this doesn’t work and throws up an error. I’ve placed the log at,

http://paste.osmc.io/ikumawefak

I can see the problem as its clearly in the log as an error but have no idea how to resolve. I’ve already removed and reinstalled the plugin but the same error occurs each time. I’ve also updated osmc to the latest rev, again with no luck.

I assume some fundamental file is corrupt and I may be looking at a fresh install…ho hum

FYI - OSMC locked up while sitting idle in the music section.

Also FYI - other addons that rely on the youtube addon still work…go figure!

It seems to be trying to re-install the youtube addon. Unfortunately the youtube addon is no longer available in the official kodi repository, you can find all the details on the kodi forums at http://forum.kodi.tv/forumdisplay.php?fid=27 or by contacting the add-on developer directly.

Development of the youtube addon have been picked up by different developers.
Full details on how to get and use the new version are here:
http://forum.kodi.tv/showthread.php?tid=267160

Thank you Spinner and yknivag for pointing me in the right direction. I’ve managed to reset the YouTube up and install my own API keys - all working again, great! :grin: