A few newbie setup questions for Vero 4K

Brilliant. Thanks again. Can’t wait to set it up.

If anybody was reading and interested, this is the USB gigabit adapter I bought:

I’ll post back to confirm it works well on the Vero 4K too.

By the way, I wonder if somewhere in the Wiki/Forums there could be a list of user reported working USB gigabit adapters. I couldn’t actually locate any explicit recommendations in the forums before I ordered the Vero 4K, which made me a bit nervous (perhaps I didn’t look hard enough). I’m happy to kick the list/thread off if someone could suggest where I put it.

Seeking “USB gigabit adapter” in this forum search above seems to return several valid results.

Thanks - I hadn’t actually thought to do that (doh).

Although most of those threads are ones I had read and are somewhat dominated by posts from people reporting issues with their adapters (although the issues may or may not be down to the adapters), which is what was making me nervous.

You are right though - there is a few posts from people solidly recommending something they are happy with. I was pleased to see one of these was for an Anker USB 3.0 adapter, which is what I bought.

PS - I’d definitely second the suggestions to have an adapter in the shop or (presumably less work) have an “officially” recommended one. I appreciate it is not a straight forward decision but depending on your average customer it could be really good for sales.

The 100 ethernet port delayed my purchase by several days, and would have averted it if the competition was better. I had a bit of a double take when I first saw in the specs (of a 4K streamer) that it was just ethernet 100. Fortunately I had the time to read on these forums, including the repeated posts by Sam explaining how it should actually be fine for the vast majority of 4K rips, and the decision process behind excluding a gigabit port. This in turn taught me about nfs, which was well worth learning about and I’ve implemented elsewhere in my network :slight_smile: But really it was hours of reading posts by people saying their 4K movies were stuttering on the 100 ethernet port, having to fiddle with nfs, playing with buffer sizes, trying the Wi-fi etc, which all did make me quite nervous.

If right from the main sales page you recommended an adapter (or had an add to basket option) for customers who are not confident in their Wifi strength, it would certainly help sales for any customers out there like me (who are aware of more specs than they understand!)

I’m still of the opinion that you do not need Gigabit Ethernet.
You have purchased a Gigabit Ethernet adapter before receiving your device. With that said, it won’t hurt.

Fortunately, users can add a variety of adapters easily and without issue. They can also probably find these adapters on their local market cheaper than we can sell them.

Selling an adapter is strange, because we’d be doing a disservice by suggesting it’s necessary, and it’s also not very appealing to have to buy an add-on. I’m still struggling to find a single 4K UHD rip that warrants this.

It’s only beneficial if you use userspace shares which have overhead. Even then, it’s still not always necessary, and we have some upcoming changes to significantly improve the performance of Kodi based shares.

Your feedback however is appreciated. I am aware that Fast Ethernet (100Mbps) is a huge put off for customers. Sadly sometimes marketing is about ticking a box without it meaning a lot.

3 Likes

Hi Sam,

I am very encouraged to hear you say that you do not think gigabit ethernet is needed. I would certainly bow to your wisdom here and would prefer to use the built in port despite having bought the USB adapter.

However, the reason I assumed I needed the adapter was post 2 in this thread:

where @fzinken says “Any file above 86Mbit average bandwidth will not be able to be played via Ethernet unless you get a USB Gigabit dongle”

One of the first UHDs I ripped was The Hitmans Bodyguard. Running media-info on the resulting m2ts, the average bitrate is reported as 89.5Mb/s, which is of course above the 86 threshold mentioned above. So straight up I thought I had a film which would not work over the built in ethernet port. I guess I have misunderstood something though…

General
ID : 0 (0x0)
Complete name : The Hitmans Bodyguard (2017)/The Hitmans Bodyguard (2017).m2ts
Format : BDAV
Format/Info : Blu-ray Video
File size : 74.0 GiB
Duration : 1 h 58 min
Overall bit rate mode : Variable
Overall bit rate : 89.5 Mb/s
Maximum Overall bit rate : 109 Mb/s

@encdpnew, my 86Mbit was a bit conservative I guess your 89 Mbit also plays fine if you use fstab based mounting.
Generally I suggest to use NFS instead of Samba if you have rips that are close to 100 Mbit.

What I’d suggest is you just try without the GB adaptor.

You might also consider using MakeMKV (free) and strip out unwanted audio tracks and subtitles. That would cut down on the network use (and file size).

many thanks @fzinken and @bmillham . Good to know 86 is not necessarily a hard threshold.

It’s good advice too to try and lower the bitrate with paired down mkvs. I actually own a MakeMkv license (and in fact use it to get the m2ts files). In my case though it was quite a considered decision to archive my UHDs as m2ts. In case anyone interested:

  • Full compatibility of HD audio with Sony Blu-ray players. Even my 4K x700 Player will only play Dolby TrueHD in m2ts, not mkv. I think blu-Ray players are underrated clients for lossless disc files - resolution switching, colour space switching, HD audio, impeccable image quality - so I’d like to keep this option as it has worked robustly for the last 10 years of my Sony players.
  • I think more chance of Dolby Vision working in the future, as the m2ts is the untouched original stream (and you can see the DV data in there as a second video track). May never work (may require full backup of whole disc) but it definitely won’t work with current mkvs, which strip the DV data away.
  • Can always convert m2ts to paired down mkv in future but obviously can not go back to untouched m2ts from mkv

Now, as it happens during setting up my system I did rip an mkv of this same film with just the Dolby Atmos and core audio saved. I just checked and - very interestingly - the bitrate of that file is considerably lower more like 76Mb/s (and the file is just 64ishgb IIRC). Since the extra AC3 audio tracks in the m2ts do not account for ~10 extra gb I think what is going on might be the Dolby Vision data. Does show though how effectively the bitrate could be lowered with mkvs. I’ll be getting hold of Force Awakens soon (another DV disc) and curious now to see if it is the same.

Anyhow, when the Vero 4K arrives later today I will try the built in ethernet port and watching the Hitmans Bodyguard start to finish and report back. While my instinct is to just use the USB adapter due to the very small amount of headroom, I’d be interested and happy to try and help prove Sam right. There’s not enough posts of people confirming it does actually work over 100 ethernet.

Are you using samba or nfs?

It will be nfs

That together with fstab based mounts should be perfect

Hi - sorry for delay - I discovered that my fileserver was not up to scratch for serving 4K media (an old MacBook Air with USB 2.0 ports). Long story short - I have now upgraded to a Synology 2 disk NAS (RAID 0), which I’ve been meaning to do for a while. It has superb read/write speeds that saturate my gigabit LAN network.

In limited testing so far - it seems to play the 4K lossless m2ts mentioned above just fine, using the built in ethernet port. It is reading from the Synology using nfs and /etc/fstab. I’ve only watched 10 mins so far but they were seamless :slight_smile:

Unfortunately an issue has arisen with colour banding. @sam_nazarko I am using your suggestion of adding the line:

echo ‘444,10bit’ > /sys/class/amhdmitx/amhdmitx0/attr

to /etc/rc.local

However, the 4K m2ts (Hitmans Bodyguard) above displays very clear banding, which is not present when playing the same file (via DLNA) on my Sony X700 4K blu-ray player (I’d be happy to send 2 comparison pictures). Both are connected to the receiver (i.e. same HDMI input on TV) with identical receiver settings (all AVR picture processing is bypassed and Enhanced HDMI is enabled).

So the Vero 4K is incorrectly handling this 4K rip (using the 444 10 bit setting), where as the Sony Blu-ray player is not. I was wondering if you have a suggestion of a different setting? I appreciate automatic switching isn’t ready yet but I’d be keen to verify the Vero can play these files correctly (with no banding), i.e. like my blu-ray player, even if I have to manually set it.

Thanks much.

Is your device up to date? We released an update today to address these very issues re. banding

If it is, I’d suggest sudo chmod +x /etc/rc.local and a reboot.

Sam

Hi - that’s great to hear! It was not up to date.

I updated it this morning but after updating my NFS shares don’t work so I haven’t been able to re-play the video. The network location is definitely online and accessible from other devices. I checked and the NFS entries are still there in /etc/fstab. But when I run sudo mount -a, or reboot, the directories I created /mnt/synology-video etc are all empty. Got to run now but will look at more tonight.

Cheers,
Paul

FWIW I figured out that the Vero 4K will no longer connect to my Synology when I restrict NFS connections by IP. Since everything is Read Only I am happy to open it up to all connections for now, but definitely want to atelast figure out how to restrict connections to my LAN. Although this broke at the same time as updating could well be something else (eg Vero 4K connects through an ethernet switch) but please anyone let me know if they’ve noticed similar issues with the update.

Anyway, more importantly, I tried the same video again after a complete reinstall and the April update. This time round I didn’t touch the rc.local but did enable the new HDR autoswitching option.

The video above now plays back perfectly without banding - exactly like my Sony X700 - so it clearly was the bug that just got squashed in the April update.

Last night I setup my movies library, reading from the Synology, and was playing various 1080p and 4K lossless blu-Ray Rips. Everything was working flawlessly: Bitstreaming HD audio to my AVR, resolution switching, framerate switching, engaging HDR on my TV for the 4K file, and no evidence of banding. Starting to fall in love a bit with this little box. Great work Sam. A bargain.

Finally, I did decide to use my ethernet adapter in the end. I noticed that I stopped getting “buffering” waits, and generally files seemed to play a bit more instantaneously (and I feel less nervous about skipping around etc) but mainly because I intend to make use of an old WD NAS which I can only connect to via Samba. However, when I was using the built in ethernet I saw no evidence it will not work with large 4K m2ts’s - everything did play fine - even via Samba (with an fstab entry) when I tried it.

Cheers again,
Paul

Hi,

I’m using nfs fstab mounts with restricted ip to my lan and updated yesterday and had no issues.

How have you formatted the ‘IP networks’ field ? e.g:

192.168.0.0/24

or

192.168.0.0/255.255.255.0

Is DSM up to date?

Thanks Tom.

Hi Tom - many thanks for offering advice. I think I might have done it wrong (although I could have sworn it worked for a day)

The static IP address of the Vero 4K on my LAN is 10.0.0.41 so I simply entered this as the “hostname”. Perhaps I needed to format it differently?

Hi,

Apologies I’m away from my nas and I read the documentation wrong, the field is indeed Hostname.

Entering the IP of your verok4 should work, I would confirm the IP of your vero4k hasn’t changed?

To restrict to your lan, this should work in the hostname field:

10.0.0.0/24

Thanks Tom.

It is working perfectly using 10.0.0.0/24. As long as is restricted to my local LAN I am happy. Everything setup now and working fantastically. Thank you!

1 Like