A few newbie setup questions for Vero 4K

Hi - that’s great to hear! It was not up to date.

I updated it this morning but after updating my NFS shares don’t work so I haven’t been able to re-play the video. The network location is definitely online and accessible from other devices. I checked and the NFS entries are still there in /etc/fstab. But when I run sudo mount -a, or reboot, the directories I created /mnt/synology-video etc are all empty. Got to run now but will look at more tonight.


FWIW I figured out that the Vero 4K will no longer connect to my Synology when I restrict NFS connections by IP. Since everything is Read Only I am happy to open it up to all connections for now, but definitely want to atelast figure out how to restrict connections to my LAN. Although this broke at the same time as updating could well be something else (eg Vero 4K connects through an ethernet switch) but please anyone let me know if they’ve noticed similar issues with the update.

Anyway, more importantly, I tried the same video again after a complete reinstall and the April update. This time round I didn’t touch the rc.local but did enable the new HDR autoswitching option.

The video above now plays back perfectly without banding - exactly like my Sony X700 - so it clearly was the bug that just got squashed in the April update.

Last night I setup my movies library, reading from the Synology, and was playing various 1080p and 4K lossless blu-Ray Rips. Everything was working flawlessly: Bitstreaming HD audio to my AVR, resolution switching, framerate switching, engaging HDR on my TV for the 4K file, and no evidence of banding. Starting to fall in love a bit with this little box. Great work Sam. A bargain.

Finally, I did decide to use my ethernet adapter in the end. I noticed that I stopped getting “buffering” waits, and generally files seemed to play a bit more instantaneously (and I feel less nervous about skipping around etc) but mainly because I intend to make use of an old WD NAS which I can only connect to via Samba. However, when I was using the built in ethernet I saw no evidence it will not work with large 4K m2ts’s - everything did play fine - even via Samba (with an fstab entry) when I tried it.

Cheers again,


I’m using nfs fstab mounts with restricted ip to my lan and updated yesterday and had no issues.

How have you formatted the ‘IP networks’ field ? e.g:


Is DSM up to date?

Thanks Tom.

Hi Tom - many thanks for offering advice. I think I might have done it wrong (although I could have sworn it worked for a day)

The static IP address of the Vero 4K on my LAN is so I simply entered this as the “hostname”. Perhaps I needed to format it differently?


Apologies I’m away from my nas and I read the documentation wrong, the field is indeed Hostname.

Entering the IP of your verok4 should work, I would confirm the IP of your vero4k hasn’t changed?

To restrict to your lan, this should work in the hostname field:

Thanks Tom.

It is working perfectly using As long as is restricted to my local LAN I am happy. Everything setup now and working fantastically. Thank you!

1 Like