A little Tvheadend help please…

Evening all,

I had a go at trying to use Tvheadend for the first time today but have run into a problem.

I followed this guide (more or less) to get Tvheadend setup:

I’ve used an old Raspberry Pi 2 v1.1 that I had lying around along with an old WinTV Nova-T stick.

I installed Raspberry Pi OS (with desktop) and then I installed Tvheadend as per the guide.

Everything went fine and I was able to scan and map 120 channels, and then view those channels in the web interface.

I then connected to the Tvheadend IP address from another PC on my network and I was able to watch live TV as well.

I installed the Tvheadend server from the OSMC App Store on my Vero 4K+ (wired) and configured the Tvheadend PVR client with the correct IP address for Tvheadend on the Pi. When I tried to enable the PVR client I got a message saying that it couldn’t be loaded.

I tried the same on my Vero 4K (wi-fi) and got the same result.

Here is the log from the 4K+:


I removed the Tvheadend server and tried again, but the result was the same:

Here’s the log:


This seems to be relevant, but I’m not sure what to make of it:

IAddonInstanceHandler::CreateInstance: pvr.hts returned bad status "Permanent failure" during instance creation UpdateAddons: Failed to create add-on Tvheadend HTSP Client, status = 5 CAddonMgr: pvr.hts disabled

Basically I’d like to have Tvheadend running on the Pi and my Veros connecting to it to stream live TV.

I should mention that I was able to get live TV working on both Veros once after toggling the PVR client a few times, but it all fell over again after a reboot.

Both Veros are updated to the most current version.

Any help would be appreciated.


Very odd. You definitely don’t need the TVH server on the Veros. I wonder whether the TVH client is clashing with one of your other add-ons. Could you try disabling them in turn?

Why did you install the TVHeadend Server on the Vero? I assume you just want to use it as a client?
The TVHeadend PVR Addon is already preinstalled you just would need to enable it and configure it (IP/User/Password) to point to your Pi TVHeadend Server.

Just for tests, could you first try with the OSMC skin (do a reboot after the skin change)?

Thanks for all the replies guys.

I’ve spent most of the day try all the suggestions and I seem to have narrowed it down to the skin.

None of my installed addons have any effect if I use either the OSMC skin or Estuary. I disabled them all and then enabled them one by one and everything is ok with the default skins.
Using Eminence, the Tvheadend PVR client will not start on a Vero reboot, or start when the Vero has booted. I’ll see if the skinner has any ideas, thanks.

Only thing I need to look into now is why my soundbar doesn’t play any audio, but the same stream through the TV speaker plays audio fine. It might be a limitation of the soundbar or TV ARC.

Currently connected like this:

Vero → HDMI → TV
TV ARC → HDMI → Soundbar

TV: LG 55SJ810V
Soundbar: Sony HT-SF150

Edit: Didn’t realise I didn’t need the Tvheadend server installed if I was only using the client side… learning curve.

Most likely a question of Passthrough capabilities of the TV ARC.
Your TV reports this, while not clear which ones it can passthrough ARC

CodingType MaxChannels SamplingFreq SampleSize
PCM, 2 ch, 32/44.1/48/96/192 kHz, 16/20/24 bit
AC-3, 6 ch, 32/44.1/48 kHz, MaxBitRate 640kb/s
Dobly_Digital+/ATMOS, 6 ch, 32/44.1/48 kHz, AFCDepValue 0x1
DTS, 6 ch, 44.1/48 kHz, MaxBitRate 1536kb/s

Did you read this Wiki?

Well that was a waste of a day…
Eventually traced the problem to the source button being stuck on the soundbar!
So now everything is working great with Tvheadend.
Thanks for all the help guys.

1 Like