AAC stream fade-in fade-out constantly


We recently bought a philips 48OLED935 and connected it to our Vero 4K. The TV has an integrated soundbar. I’ve set the sound to passthrough all supported formats (which is all formats).
I followed the Audio hardware and software configuration guide.

The problem now is that whenever there is an AAC stream, that stream will fade in / out every few seconds. The only way to get a working AAC stream is to set Output configuration to fixed (which removes all passthrough options). From what I understand, this will force a transcoding of all audio streams to happen, which is not what I want to happen.

I’ve tried changing different sound options but so far, I either get full transcoding of every stream or an AAC stream that fades in and out constantly.

Did you set the number of channels to 5.1 (or whatever the soundbar supports)?

Logs would be helpful :wink:

I’ve tried setting channels to every possible option. I don’t notice any change with the fade-in/out.

I’ll try to get some logs during the day :slight_smile: (working right now).

I’ve uploaded a log: https://paste.osmc.tv/ajazupezej

Try setting your GUI resolution to 1080p60 and using a whitelist so that videos play in their native resolution and refreshrate.

We recommend people with 4K TV’s set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. *Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.


Thank you for the information.

Setting the resolution to 1080p with an empty whitelist and refresh rate on start/stop fixed the problem I had with aac and vorbis audio streams.

I had not realized that setting the GUI resolution to 4K would put extra strain on the device.

1 Like