Accessing NFS share from a popcorn hour

I currently using my popcorn hour as a nfs server… I was about the access my videos with XBMC but when I tried to access them with my Raspberry Pi 2 with OSMC I get this error:

mount/mnt call failed with “RPC error: Mount failed with error MNT3ERR_ACCES(13) Permission denied(13)”

I tried to add “insure” to the export but when I reboot it overwrites with the original information.

Any idea how to access my NFS share?

Is there a way to change the way OSMC handles NFS permissions… I don’t have this problem with RASPbmc.


OSMC uses high numbered ports to connect with the NFS server.
On your NFS share, set the “insecure” flag, this will allow OSMC to connect on any port.

Is there a way to change this… I don’t have that much control with the popcorn hour. I can manually change add insecure to the exports but when I reboot it just reverts it.

This is not something from OSMC, but from Kodi … It’s been the same case for ages

Sam is looking into it after i proved some info this morning.

Btesoroni Sent you a pm as i have an off topic pch question. . Hope you can help

In this case there’s not much I can do here, but I’ll see if any commit introduced new behaviour in Kodi. You may have noticed in another thread that binding to privileged ports (<1024) was not working and preventing people running the Kodi web server on port 80. I fixed this issue, and it is possible this will resolve the issue here as well. We will find out soon enough in the next release I suppose

Bump it after the new big announcement at if the issue still persists