Aeon MQ7 Krypton sometimes fail on restart Pi2

I have the latest OSMC (Krypton) and the latest Aeon MQ7 skin (

Everything works wonderfully, until I restart. Then, about half the time, it resets the skin back to default (which you have to watch it do, adding insult to injury).

I have tried many things including installing fresh on a new SD card, to no avail. Fortunately I have backups.

My best guess what is happening is that the skin is writing its current state to the SD card on exit, and that this is being interrupted by the shutdown/restart.

Any ideas what to do?

Set things appropriately and then go back to the main menu and “Exit” Kodi. This should allow the guisettings.xml to be written correctly. Wait about 10secs and Kodi will restart, hopefully with all your config still intact.

This does work, while the device is to remain powered.

But when I need to shut it down I run into the same problem. I’ve started just shutting off the power bar, and that seems to work, but probably isn’t overall the best thing to do.

This will again create the problem you are here trying to resolve!

I wonder if it is possible, instead of shutdown, I could create a custom command that would launch an independent process to run the shutdown command 10 seconds in future, and simultaneously close Kodi before the shutdown happens.

Or, almost as good, just exit to a command line.

Why must it be turned off? The device is designed to run 24/7 or it would have come with a power switch.

the cost of running a rpi year around

At 3.5W maximum
285.71 hours to use 1kWh
30.77 units per year
13.2 pence per unit (direct debit nationwide average feb 2012)
£4.06 per year running costs

1 Like

Maybe I’m getting off track. My original problem was with restart. If I use Exit, sometimes OSMC does not re-launch. If I use Restart, it always relaunches, but sometimes it loses my settings. I don’t think the settings it loses are only in guisettings.xml but also in the addon folder for the MQ7 skin (many xml files)

I need the system to restart so I can test adjustments to the config.txt that I’m attempting to optimize for my uses.

I need the system to shut down because it’s plugged into the same power bar as other devices which need to be shut down daily. Not really many options there unless I run another extension cord just for the Pi.

EDIT: Feb 10

The recent update which claims to reduce this problem has not reduced it for me. I created some addons to replace the “restart” and “shutdown” functions.

They depend on “at” being installed.

sudo apt-get update
sudo apt-get install at

Each addon zip contains three files: (same for both)

import xbmcaddon
import os
addon = xbmcaddon.Addon()
cwd = addon.getAddonInfo('path')
os.system('at -f '+os.path.join(cwd, ' now')) 

addon.xml (the following is for Shutdown… edit in four places for the restart version

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<addon id="" name="Shutdown Now" version="0.0.1" provider-name="Me">
    <import addon="xbmc.python" version="2.1.0"/>
  <extension point="xbmc.python.script" library="">
  <extension point="xbmc.addon.metadata">
    <summary lang="en_gb">Shuts it down now</summary>
    <description lang="en_gb">No really, it shuts it down now</description>
    <disclaimer lang="en_gb"></disclaimer>
</addon> (insert -r after shutdown for restart)

sudo systemctl stop mediacenter
(sleep 20 ; sudo shutdown now) &

While I’ve never encountered a problem using this method, it could just be luck… but it’s what I’m using now instead of the default Shutdown and Restart (or Exit).

Of course, as I discovered, this doesn’t stop someone else from shutting down the system the bad way, via Yatse (or ssh too probably), and corrupting the data. I hope this gets fixed soon. There is apparently a way a program can tell the shutdown process that it isn’t ready to shutdown yet…