After last update remote not working

Unfortunately I can’t send you logs or tell you which version I’m on. I can’t navigate without remote.
The first June update worked without issues. A few days later I got another prompt for an update. So I guess it was the 2nd June update. It’s strange though, because os-release still shows 2020.06-1.

But I connected via ssh and here’s some info:

[osmc@vero 0 ~]$ uname -a
Linux vero 3.14.29-158-osmc #1 SMP Thu Apr 2 18:40:24 UTC 2020 aarch64 GNU/Linux

[osmc@vero 0 ~]$ cat /etc/os-release
PRETTY_NAME="Open Source Media Center"
VERSION="June 2020"


dmesg output:

If you tell me how to turn on debug mode on the commandline, I will get you the logs.


You can add the following to advancedsettings.xml:


If you then issue:

sudo systemctl restart mediacenter
grab-logs -A

Thanks Tom.

What remote are you using?

This is an OSMC remote on a Vero that is not working at all? The only change that has been made with recent updates was with the keymap but that only affects one button. I would try changing the battery and/or re-pairing the remote. You might also plug it into a PC and make sure it works there. What the buttons will will map as on a PC can be found [here]

What remote are you using?

The one that came with my Vero4K (bought it Sept. 2017).

This is an OSMC remote on a Vero that is not working at all?

I don’t understand the question. It worked until recently. After the March or whatever update the long-press actions worked perfectly.
Now, nothing works. Not a single key press. None of the keys. So, I guess it is not working at all.

I changed the battery 2 hours ago, just to be sure. :wink:

re-pairing the remote

I’ll try that in a few minutes.

  • Remove the USB from Vero 4K / Pi
  • Hold Home and OK button for 5 seconds or so, then the blue LED will keep flashing.
  • Plug in the USB receiver and the LED should flash 3 times after 5 seconds, indicating successful pairing.
  • Power off Vero 4K / Pi for 2 minutes. Turn it back on. The remote should now work.

Make sure you swap it out for a battery that isn’t dead.


Logs available at

From a quick glance, the dongle does not seem to be detected.


Have your tried Sams suggestion:

Thanks Tom.

Hmm, I replied per email, but my answer never showed up here. Strange.

The re-pairing does not work. The blue LED does not start flashing after 5 seconds of pressing Home and Ok.

However, after it did not start flashing blue, I turned off the Vero (pulled the plug) for approx. 2 minutes. After that I tried to do the re-pairing again. No flashing. Then I put the USB receiver back into the port and et volià it worked.

Hmm, I’m a bit puzzled. So either the re-pairing worked (without all the LED blinking) or all that was needed was to unplug and plug in the USB receiver.
In either case, it’s strange that this happened out of the blue (pardon the pun).

I’m glad all is good again. I’ll remove the debug level and reboot. Thanks!

This forum doesn’t support replying by email.


My unit hasn’t worked for probably two years at this point. It got used only so much so it’s not like the buttons have worn out. I have tried getting it to work again several times since then.

I have tried the suggestions of holding the home and OK buttons (light just stays on, does not blink; tried with both the dongle unplugged and plugged back in) and have replaced the battery several times with different batteries. I’ve powered off the unit, I’ve left it unplugged for several minutes, I’ve tried a few different drives. I’ve unwired and rewired up the entire Vero system including the HDMI cable because why not at this point.

Is there something I’m missing or didn’t try? Unless there is something else that can be tried or done, I give up.

Make sure you’re using the correct dongle (the one supplied with the device). Show us a photo if unsure.

It is the correct dongle; it’s the only one I’ve ever plugged into the box. Aside from swapping in a new drive, I don’t mess with it, I hooked it up when I got it and left it alone ever since until it wasn’t working.

I went to use it one day and the remote was simply no longer working.

Some logs should let us see if the receiver is being detected.

Thank you for your quick reply. :smiley:

How and where can I find those logs? Can I hook up some other device to the player to operate it or are they stored on the drive I have connected?

Just to be thorough, I took some photos of the dongle.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

I can’t do that because the remote doesn’t work so I can’t switch to any menus or settings.

Use SSH or connect a keyboard and use terminal to issue the grab-logs -A command.

Details regarding how to access the command line interface can be found here on our Wiki: Accessing the command line - General - OSMC

Here is the URL for the log:

I really appreciate you helping me out but it is the weekend and I’m sure you want to spend your time doing whatever you do for fun and relaxation. I haven’t had the box working in a long time so a few more days certainly isn’t going to hurt. :smiley: