After update to July version MKV videos not playing / no sound

Hi All,

so finally I also did the upgrade and unfortunately ran into a problem.
Some of my videos (avi/mp4) are playing fine but all my MKV (recorded from DVB and transcoded to x264 and mp3 are not playing at all in standard setting maybe a single frame shown but thats it the logs for that are here http://paste.osmc.io/nucojewipu.
A small sample of the file can be found here: https://dl.dropboxusercontent.com/u/88660355/out.mkv
All of that files are playing 100% fine on the same machine when I use a SD card that I have not upgraded.

Cheers

Fred

Unfortunately I don’t have a solution, but rather the same problem. The mkv files I created from DVD won’t play audio when the audio has been encoded in mp3. Aac audio does work. There was no problem before the July update. I was waiting for the promised weekend update to see if it fixes this bug before posting myself :wink:

wasn’t aware of such a magical promise so posted today :slight_smile:

Does the same file have problems in Kodi on any other platform such as windows?

I’ve tried the sample on Kodi for x86/linux and it behaves badly. No audio and video has corruption and plays poorly.
You get the same effect on the Pi with omxplayer disabled.

Best to report this on Kodi forum. Looks like Kodi doesn’t like the mp3 in this file.

Valid question, just tried it on my Ubuntu machine and there the video plays but yes you are right no audio. So as @popcornmix wrote seems to by a Kodi issue will report there.

Similar reports here: http://forum.kodi.tv/showthread.php?tid=233031
Are you recording with MythTV?

Thanks for the info, while I already had open a new thread but I add that info. I am not recodring with MythTV but VDR. But I use handbrake to convert similar like the guy in the thread.

You might have found this by yourself by now, but the information might be helpful to others who encounter the same issue. Repacking my mkv files with mkvmerge helped “repair” the files and mp3 sound is back on my Vero.

This thread helped me resolve the issue quite fast

No, haven’t spend too much time on it (falling back to 14) but now that you write it I will try it this evening first thing

Ok, can confirm that the mkvmerge solves the issue while reading on handbrake forum seems still handbrake doesn’t see it as an issue. Will add the mkvmerge to my transcoding script.

13 posts were split to a new topic: Being called “dunb” - Audio problem with MKV (handbrake) files

Update from @popcornmix

The bug is considered to be in handbrake and should be fixed in 0.10.3:

This is the fix in fmpeg which specifically works around the known problematic versions of handbrake:

As such, remuxing the problematic files is probably the technically correct solution, as they had a problem that will potentially affect other players.

Otherwise you can revert to an older version of Kodi, or to the Jarvis testbuild which should contain the ffmpeg workaround.