Allo Boss DAC support

The Wiki explains how to use the command line. Overlay only needs to be applied once and can be done from My OSMC or by editing config.txt. I actually assumed that you’d done this already to verify that the support for this DAC wasn’t currently included

The kernel will be released when it’s ready. I expect we will have some tests available in the staging repository in a few days.

yes I did look for the Boss DAC in “My OSMC” but I wasn’t entirely sure that switching there was the same as changing config.txt

So once it’s supported it won’t be necessary to edit config txt you can just do it in My OSMC is that right?

can I switch to get updates from the staging repo so I get the supported version as soon as possible?

there are no results for “repository” in a search of the wiki.

Yes you can easily do so by changing the repositories, but I suggest in the preparation for that first get familiar with the command line.

I’m looking for some specific info here:

what is the name and url of the “staging” repo with newer kernels?

are we talking about a raspbian repo (I assume) or a specifically osmc one?

is there a guide to adding / changing the system repo in osmc specifically?

Is there a general guide to changing it for raspbian in the terminal that works on osmc too?

I’m not unfamiliar with the command line, but different distros require different procedures and I certainly don’t keep much of it in my head. I have very poor memory for arbitrary information that is not linked to a discoverable context (such as terminal commands) so I usually have to look things up for exact syntax and distro specific variations even if I’ve done them several times before.

Its a OSMC Specific repo, but expect breakage its not for everyone…

A forum search will reveal this information.
I do not recommend it if you want a production / stable system.

so are we not talking about the raspbian staging repo described here? it looked from that like i just needed to add -staging to the repo name

I have searched, I’m not sufficiently sure/specific what I’m searching for…

then its better to wait for support to drop in production

this post Still not getting automatic update install

seems to say the osmc staging repo is called -devel

ie deb http://apt.osmc.tv jessie-devel main

that is pretty much the info i was looking for. it just took a while of reading between the lines to get enough context to search for the right thing.

of course I would rather stay on the regular repo and just use the kernel from -devel although i guess that might cause other problems.

BTW I don’t think “if you don’t know already then you shouldn’t ask” is a helpful approach to learning this stuff

No one said that. We just said search. You did, and you found the solution :slight_smile:

and again EXPECT breakage this is not a stable repo, you have been warned of this now.

thats why we dont recommend users that feel insecure about how to handle commandline to do this, its not cause we want to discourage em just that it can cause instability in your mediacenter and if your not familiar with commandline or linux in general the experience might not be so pleasant.

I had searched extensively, but i needed some extra bits of info to construct a search term that found me anything useful. For example it isn’t clear straight away that osmc updates exclusively from it’s own repo, it could be pulling the base system from vanilla raspbian.

yes I’m duly warned that it is an unstable repo. The kernel I need however is already the default in various products , ie volumio, dietpi, max2play so I’m assuming/hoping it isn’t too unstable, even though the -devel osmc repo may be overall. That may be a wrong assumption, maybe none of those products are stable, certainly I couldn’t get volumio working correctly.

thing is really i don’t need or want to switch to -devel, I just want to swap out the kernel for a newer/custom one - I’ve done this before on desktop systems , can’t remember how and wouldn’t assume it was the same so I hoped maybe there was a guide for doing that somewhere…

at this point I am just testing - I don’t absolutely need anything to work - it’s linux after all. I’ve never had a linux based system I didn’t have to fix something on myself… and I’ve tried loads of them.

but maybe you are right, although I can probably handle using -devel if I have to it may be more effort than is reasonable for the results if the DAC drivers inclusion in the release system is imminent anyway.

i guess I can try dietpi with kodi to get the DAC going and come back to osmc once the 4.9 kernel release is out. I’ll see how much time I have to mess with it.

Well I got it working in vanilla raspbian/pixel. Very easy once I found out how!

I haven’t tried this in OSMC so it’s a little bit OT here but since the thread exists I thought I’d add the info in case it is useful to anyone.

I used rpi-update. description and info on that is at: https://github.com/Hexxeh/rpi-update

this gives you the latest bleeding edge kernel/firmware without having to change repos

this updated the kernel to 4.9.23 and the boss dac overlay then appeared in the /boot/overlays directory

then I had to add a line to config.txt in the /boot/ directory

allo-boss-dac-pcm512x-audio.dtbo

I had thought/hoped that this line would have been added but commented out by rpi-update but it wasn’t and had to be added manually. no problem though.

reboot after all that and it seems to work fine. Of course it may have broken something I haven’t noticed yet.

I’d be interested to know if this procedure would work on OSMC or if the kernel and boot setup is too different from vanilla raspbian

Again: searching for rpi-update would give you your answer.

We do not recommend or support using it. You can try it, but you’re on your own. You will break support for other things by doing so.

You still haven’t confirmed if you tried setting the overlay on OSMC yet.

Seriously: just wait for 4.9 to come as an official update. The more searching you do, the more time I will have to work on the new release instead of replies :wink:

Thanks for your understanding

yes I confirmed that I tried setting the overlay in My OSMC (back in post 5 on this thread) however I have not tried from the command line.

When I tried the Boss Dac was not listed, which is not surprising since support was only added in kernel 4.9 (I believe)

When I bought the DAC I didn’t realise just how new and unsupported it was, although hopefully the support will be widespread soon.

I certainly don’t expect you Sam, as the main dev on OSMC to reply to every question on this forum! That’s sort of the point of a public forum is that users can help each other and share their experiences. please don’t think that I expect the lead dev to answer everything as a support request.

So I appreciate the replies, but I don’t expect them!

I will indeed wait until 4.9 is included before trying OSMC again, in the meantime i’ll try Kodi with raspbian/pixel and see how I go with that.

The plan is to get 4.9 building (and available for testing) early this week. You are indeed correct that support was introduced in 4.9; there are so many DACs it is hard to keep track of all of the new ones now.

Keep an eye on this thread. I’ll let you know when it is ready

Hi, I have updated OSMC to the latest May release but the Allo Boss Dac is still not listed in the hardware support - soundcard overlay. I could see Allo piano and few other dacs but not Boss, can any user help regarding this and provide information on how to activate the sound card…thanks in advance …Regards Maverick_SS

I believe you can do it via config.txt. We only list the most popular DACs

We have moves to Linux 4.9