Any way to force resolution (fw_setenv) using the GUI

Forgot my OSMC password that I had set, so only alternative now is the do a complete re-install. I have everything working perfectly especially with the test 3D build, so don’t want to re-install and configure everything again. All I want to do is force resolution after boot or after change from 3D movie to 4K movie where Vero goes back to a crappy resolution that looks bad on the projector screen. One way to do that is using a forced resolution using the fw_setenv command on the command line:
sudo fw_setenv hdmimode 1080p60hzforce
sudo fw_setenv outputmode 1080p60hzforce

Is there an equivalent thing using the GUI like configuring the OSMC skin?

Or a way to get to the command line without rebooting and requiring a password?

Normally you would just set your GUI to 1080p and enable refresh rate change and Kodi will automatically change resolutions. If you enable a whitelist you gain more control over the resolutions including the ability to switch resolutions on the fly during playback from the OSD setting button where the player controls are. You can find more information on how the whitelist works in the following guide…

fw_setenv affects the resolution at boot-up only. Once Kodi starts up,it is in control.

1 Like

Probably my issue is different then … Once I reboot and start up OSMC, the initial resolution of the On screen GUI that comes up is terrible … there is overscan and the logo is stretched across left and right. Now if I select and play a UHD movie, pause the movie and get back to the Home screen the resolution is perfect. Everything is nice and beautiful. I am trying to figure out a way to get this resolution after initial start or a reboot. Tried the “sudo fw_setenv hdmimode 1080p60hzforce; sudo fw_setenv outputmode 1080p60hzforce; reboot” commands and still the initial resolution after bootup is messed up.

My connection is Vero 4k+ → Denon AVR X4700H → Sony Projector VW695ES

I do have the recommended settings:

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/stop

I would guess there is something a bit off with the edid of your projector or AVR that is causing this. There is a way to correct this but it requires access to the terminal so you will have to get that other issue sorted first. If you search this forum for something like “vero custom edid” you should find plenty of info on creating and tweaking the display data Kodi is using.

Perfect … my console logging issue is sorted with the solution posted. I will search for “vero custom edid”. Thanks!

Tried the following … GUI after reboot is still messed up :frowning:

sudo cp /sys/class/amhdmitx/amhdmitx0/disp_cap /home/osmc/.kodi/userdata/disp_cap
sudo chown osmc:osmc /home/osmc/.kodi/userdata/disp_cap

That copies your existing info that is problematic to a location where it can be modified. Until you modify that file it is going to act the same as it did without it. I think with your issue it is probably just a matter of moving the asterisk to the desired resolution but @grahamh is probably better to advise than me. If you…

paste-log /home/osmc/.kodi/userdata/disp_cap

at the terminal it will return a url that you can post in this thread that will allow us to see the contents of this file.

Here is the URL from the above pase-log command:


Nothing wrong with that. Please post full logs after a reboot.

Here’s the full logs:

I can’t immediately see anything wrong there:

2021-04-05 16:57:19.714 T:4065291456 INFO: GUI format 1920x1080, Display 1920x1080 @ 60.00 - Full Screen

Are there any settings on your projector to adjust out the overscan?

Yes … there are settings on the projector … don’t want to mess with that as I have multiple devices connected through my AVR and don’t want to cause any issue with the projector …

I will just live with this for now … after I play a 4K HDR movie or a 3D movie, the resolution of the GUI is perfect. Since the Vero 4K+ is never turned OFF, it remains in this good resolution for the GUI until a next reboot.

Thanks for all the help and support … this forum is just great!