Apt-get update error "Unable to locate package apt-transport-https"

Hi darwindesign,

Thanks for your reply,

No, the file sharing is setup correctly with no passwords, etc. I can open the shared files from another Windows computer.

I noticed that there is no Samba menu option in OSMC which I am assuming would be there if I installed it from the (un-accessable) App Store.

It’s a shame if I have to ditch the box because I can’t get Samba to work as I do need to be able to access the shared files on my USB Enclosure.

As this device is stuck forever on a very old version of Kodi I think you will find that the vast majority of add-on’s that connect to internet locations no longer work.

I didn’t know that.

Audio only Airplay works but casting video via Airplay doesn’t work with any version of Kodi from any modern iOS device.

Both Audio and Video Airplay are working from the latest version of iTunes on Windows. No problem there.

That device can’t even output full HD can it?

Yes it does Full HD but that is the maximum resolution.




Hi Sam,

I am very close now that I managed to install Samba and smb-app-osmc and would appreciate your help.

When I browse SMB I get a blank screen (no shares show) and I don’t know whether the version of smb-app-osmc that I found is too new for the Apple TV box OSMC installation of 2017.08-1.

The versions on that website were 1.2.6 and 1.2.7.

Are the versions too new for my Apple TV box OSMC installation of 2017.08-1?

Why can’t I see any shared folders when I browse to the SMB option?

Do I need to modify the configuration files for Samba?



There is your problem, without password would indicate guest account which is not supported.

Hello fzinken,

I created a local user in Windows and added the user with read access to the 2 shares.

Then on the OSMC box I adduser [windowsusername] then smbpasswd -a [windowsusername] but I still get an empty screen when I try to browse smb



This is unnecessary, once again you are mixing up client and server.

First step run on OSMC smbclient -L and see/post the outcome.
as a next step try to add -u WINDOWSUSERNAME before the -L

smbclient -L
-bash: smbclient: command not found

Is it possible that the versions of smb-app-osmc that I found are too new for the Apple TV box OSMC installation of 2017.08-1?

I opened the older of the two (smb-app-osmc_1.2.6_all.deb) archive and the files are dated 2020.



No, not related the smbclient is another package that you then need to manually install similar as the samba package you installed

Hi fzinken,

OK installed smbclient.

Output is as follows:

smbclient -L
Enter osmc’s password:
protocol negotiation failed: NT_STATUS_CONNECTION_RESET

smbclient -U=sambauser -L
Enter sambauser’s password:
protocol negotiation failed: NT_STATUS_CONNECTION_RESET

I found the following on another webpage:

Win10 no longer enables SMB1 by default in new releases. Regrettably, Linux file managers can only access samba servers using SMB1 which results in the exact error message you received.

You can verify if this is the problem by invoking the following command - replace with the ip address of the Win10 machine:

Code: Select all

smbclient -L

If it’s the SMB1 problem you should get this error message:

protocol negotiation failed: NT_STATUS_CONNECTION_RESET

I am running current Windows 10 releases on our computers.

EDIT: The 4.13 Linux Kernel changed the default CIFS SMB version from SMB1 to SMB3.

I checked the Linux Kernel version on the OSMC box and it is 4.2.3-25-osmc so I think this is why I am getting a blank screen.>

[1] On the smbclient end you edit /etc/samba/smb.conf and add the following line - right under the workgroup = WORKGROUP line:

Code: Select all

client max protocol = SMB3

I tried to create a new /etc/samba/smb-local.conf and added the line but it is still using the /etc/samba/smb.conf

Load smb config files from /etc/samba/smb.conf
Processing section “[osmc]”
Processing section “[automount template]”
Can’t find include file /etc/samba/smb-shares.conf
Loaded services file OK.
This warning is printed because you set one of the
following options: SO_SNDBUF, SO_RCVBUF, SO_SNDLOWAT,
Modern server operating systems are tuned for
high network performance in the majority of situations;
when you set ‘socket options’ you are overriding those
Linux in particular has an auto-tuning mechanism for
buffer sizes (SO_SNDBUF, SO_RCVBUF) that will be
disabled if you specify a socket buffer size. This can
potentially cripple your TCP/IP stack.

Getting the ‘socket options’ correct can make a big
difference to your performance, but getting them wrong
can degrade it by just as much. As with any other low
level setting, if you must make changes to it, make
small changes and test the effect before making any
large changes.


Press enter to see a dump of your service definitions

My first question is how do I get Samba to use the smb-local.conf file instead of smb.conf?

All I did was copied smb.conf to smb-local.conf, pico /etc/samba/smb-local.conf and added the client max protocol line.

If I put that line in smb.conf I am getting some results when running smbclient (still some errors but different to before).

For some reason it is not referring to smb-local.conf

The first line in smb.conf is

config file = /etc/samba/smb-local.conf

It is not # commented out.




If you with the blank screen to Kodi then you would configure the SMB protocol under Settings - Service - SMB Client


If you issue is smb3 then run

Smbclient -m SMB3 -U=sambauser -L

Hi fzinken,

I am getting some results if I add the client max protocol = SMB3 to smb.conf but if I add it to smb-local.conf it is not being loaded.

Any idea why?

We are soooooo close.



Hi fzinken,

If you issue is smb3 then run

Smbclient -m SMB3 -U=sambauser -L

smbclient -m SMB3 -U=sambauser -L
Enter sambauser’s password:
Domain=[FBLAPTOP2] OS= Server=

    Sharename       Type      Comment
    ---------       ----      -------
    ADMIN$          Disk      Remote Admin
    Audio           Disk
    C$              Disk      Default share
    E$              Disk      Default share
    G$              Disk      Default share
    IPC$            IPC       Remote IPC
    Video           Disk

Connection to failed (Error NT_STATUS_RESOURCE_NAME_NOT_FOUND)
NetBIOS over TCP disabled – no workgroup available

So next step configure min/max protocol in Kodi under setting - service smbclient and you should be done.

The shares are not appearing when browsing through OSMC, they only show when I do the smbclient command.

I don’t know why.

The settings SMB Clients settings are only:

Workgroup - WORKGROUP
WINS server -
Maximum protocol version - SMBV3

Have you enabled expert setting?
Not sure that the minimum setting only came with a newer Kodi version?

Maybe share logs via grab-logs -A maybe we see what is wrong.
alternatively if smbclient works maybe not use Kodi mounts but use kernel mounts (or autofs)

When you posted you ran the XP installer I got the impression that you were running XP where netbios and SMBv1 hadn’t been depreciated yet. With modern versions of Windows you don’t want to use passwordless/guest sharing and you can’t without some extra effort and headaches. Your source in Kodi would then look more like…


Unless you want to do the system mount as fzinken suggested…

Hello fzinken and darwindesign,

I have good news.

I found the webpage https://osmc.tv/wiki/general/file-sharing-with-a-nas,-media-server,-windows-share-or-other-device/

And found the relevant points of:

You cannot currently browse to SMB servers if using the latest version of the SMB protocol.


Instead of entering the whole string for each share, you can choose Browse and then Add network location. Enter the server name or IP address in the Server name field and enter appropriate credentials for access to the server in Username and Password. Hit OK and the server will now appear in the ‘Browse for a new share’ list and you can then browse to any SMB shares on that server available to user.

So I did that and I can access my shares.

Performance sucks and the box was continually rebooting as it grabbed the movies in my folder. Playing movies was ok.

I am now looking at https://discourse.osmc.tv/t/mounting-network-shares-with-autofs-alternative-to-fstab/74228 to see if performance will be better.

I really want to thank all of you @sam_nazarko, @fzinken and @darwindesign for your patience and help throughout the ordeal. I am pleased to say we got there in the end!!!



Well I tried the Mounting network shares with autofs (alternative to fstab) but I am not getting anywhere.

I added the following line to /etc/auto.smb.shares

/mnt/FBLAPTOP2/Movies\ &\ Other\ Video -fstype=cifs,rw,credentials=/home/osmc/.smbcredentials,iocharset=utf8,uid=osmc,gid=osmc,vers=3.0 ://\ &\ Other\ Video

I then run

sudo systemctl restart autofs

Then execute:

ls -lah /mnt/FBLAPTOP2/Movies\ &\ Other\ Video

I get the error:

[1] 5929
-bash: Other Video: command not found
osmc@AppleTVBox:~$ ls: cannot access /mnt/FBLAPTOP2/Movies : No such file or directory

What am I doing wrong?



Your trying to mount a share that doesn’t exist.

I just followed the instructions in the webpage https://discourse.osmc.tv/t/mounting-network-shares-with-autofs-alternative-to-fstab/74228

What do I need to do to get it working?

It seems like the spaces and & sign in the share name is causing the problem.