ATV1 Update 2017

After installing the latest update, OSMC would not boot and will only display a sad face that would loop. Tried downloading and installing the latest version as well as the DEC 2016 version and it sits on ‘installing’ with a full progress bar. A friends ATV has done the same after installing the update.

Have you tried the solution explained in the first question?

Another common problem for ATV users, is that the Boot partition becomes read-only.

If the boot partition was read-only when upgrading, the upgrade will fail to fully complete.

Typically because the device is not properly being shut down before the power is removed…

1 Like

Here’s is full info:

if you post logs we can confirm if that is the problem.

I have most definitely had power cuts at my house whilst using my ATV1 running CB2. Ergo, I assume that I have “incorrectly shut down” my ATV1, right?

As this is the case, the obvious question is: is there any remedy for a read-only partition?

Did you click the green title link in spinner’s post above?

Oh… whoops! I have now, and it’s all explained perfectly. Silly me, sorry! Thanks for the heads up.