Audio dropping/cutting out in movies via VERO4K/OSMC

Hi everyone.

As long as I can remember with OSMC I randomly get audio dropouts (or suddenly really low volume) when playing a movie.

The drop is less than 0.5 seconds, so that’s why I’ve lived with it so far but it is annoying.
When I play directly from my LG TV instead of via OSMC there’s no issues.

I’ve looked online, but to no avail.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

1 Like

Thanks for the instructions.
The logs can be found at:

The issue presented itself in the last 10 seconds of playing a video file just before I uploaded the logs, so it should be near the end.

Change your audio channels to 7.1 and your UI resolution to 1080p and test again.

We recommend people with 4K TV’s set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. *Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

Hi Darwin,
Thanks for your reply!

Some questions:

  • Curious why I should set it to 7.1 when I actually have a 4.1 setup?
  • 1920x1080p which framerate?

I will try the suggested changes and get back to you

Try 60Hz.

Why have Kodi do (and take CPU cycles for) what your AVR is better equipped for? Passthrough will not be affected either way.

Thanks for the suggestions. After the October update I began to have the same issue and I will try your solution.

Keep us posted if it helps for you!
I changed the settings but haven’t been able to sit down and really watch something yet.

So the volume drops seem to have become less but now I had really loud CRACKS/POPS in the sound, and sometimes still volume dropping.

In this logfile
timestamps (from the video i had on, but I started the logging after the video was already running for a little while… ):

loud crack/pop between
12:00 - 12:10
12:30 - 12:40

volume drops:
18:50 - 18:59
27:32 - 27:42

Maybe related to this?

2020-10-30 19:12:00.169 T:3327869152 DEBUG: Readrate 60000 is too low with 4079033

If I search that log for “DEBUG: Readrate” I get over 8k hits.

You might try taking one of these files your having an issue with and try playing it from USB storage to see if the issue really is with Kodi and/or your audio settings and not something to do with your connection to your source.

Also, and this is probably unrelated, I spoke in error when I said for you to change your channels to 7.1. I only looked that you had it set to 4.1 but didn’t notice what your equipment is reporting as supported, which is only 2 PCM channels, which is what it should be set at.

Hi Darwindesign, thanks for your swift reply.

I will try playing from USB, but I’d be surprised if that’d be the case since playing from LG webOS works fine - and the issue in kodi persists on anything from very high bitrate DTS-MA 4K files to crappy 1080p files. It also doesn’t seem to happen more often on bigger files. I also don’t get any stuttering or whatever.

This part confuses me - could you explain what you’re talking about?:
I only looked that you had it set to 4.1 but didn’t notice what your equipment is reporting as supported, which is only 2 PCM channels, which is what it should be set at.

It shouldn’t be just 2PCM channels as I have a 4.1 setup and it’s supposed to pass through DTS (or whatever codec is used) to my receiver. The video file I was playing didn’t have DTS audio or anything though.
Either way I’ll set it back to 4.1 then?

The “channels” setting is how many PCM channels it can output to. As per your logs you equipment is reporting support for only two PCM channels.

====================== Audio Cap =================== k3dRrf31
CodingType MaxChannels SamplingFreq SampleSize
PCM, 2 ch, 32/44.1/48/96/192 kHz, 16/20/24 bit
AC-3, 6 ch, 32/44.1/48 kHz,  bit
Dobly_Digital+, 8 ch, 32/44.1/48 kHz, 16 bit
MAT, 8 ch, 48 kHz, 16/20 bit
DTS, 6 ch, 44.1/48/88.2/96 kHz,  bit
DTS-HD, 8 ch, 44.1/48/88.2/96/176.4/192 kHz, 16 bit

---------------------- Audio Cap END --------------- k3dRrf31

That setting does not affect bitstream/passthrough. It affects anything that isn’t bitstream.

Hmm. How exactly is your hardware connected?

Right now I’m using HDMI ARC, so OSMC is directly connected to my TV, which is connected to my receiver.
When playing DTS file I can see the receiver is receiving DTS.

OSMC isn’t connected to my receiver directly because it’s a 1080p receiver. (I do have a hdmi splitter (similar to HD Fury) with which I could connect OSMC Audio to receiver and video to TV in case I want to watch MA Audio since that can not done over HDMI ARC Passthrough. But that method gave me a lot of troubles when using other sources than OSMC)

Maybe DD+ is having an issue going through ARC? Have you tried passthrough with only the AC3 passthrough enabled?

I’ll try that but my first tests indicated that this means having to watch in stereo (at least, if the file is DD+ surround, and I disable DD+ passthrough, it plays in STEREO instead).

Another thing I have noticed, is that if I don’t do anything in the menu for 2 seconds, then the first menu action (eg pressing ‘down’) is muted, the 2nd press is audible but silent, and after the third press it’s full volume until I stop pressing something for 2 seconds again. Then it starts over. It didn’t use to be like that, maybe it’s a change in kodi, but I figured I might mention it in case it’s connected. This topic seems similar Silence at the beginning of media/menu sound playback. - I figured “keeping audio alive” would help but it doesnt

If you turn off DD+ transcoding then it will output as PCM when playing that type of source audio and, with your current configuration (ARC), that is limited to stereo. You can enable AC3 transcoding to overcome this but the goal was to try to narrow down where the issue is.

Given your description of your setup I wonder if you might be better off just running the Vero’s audio to your AVR via toslink instead of via ARC.

Understood - will try it out.

I actually tried some other solutions I found (eg installing pulseaudio) but that cause my audio to completely stop working. So I had to do a full reinstall, and so far it seems that might have solved the problem as well! I’ll try to watch a full movie today and mark this as solved in case it is really gone.

Yes, pulseaudio doesn’t work under Buster. Let us know how it goes with the new install.