Audio stutter for 1 second every 27 seconds

I searched support and don’t see any recent reports of a similar nature.
I’m using a Vero 4k+ with the development build as of last night.

Logs: https://paste.osmc.tv/lavisaleji

I’ve noticed today that I’m getting a 1 second pause in audio every 27 seconds when playing certain things.

I gathered more info after I saved a log, I’ve detailed log entries below.

Music Player:
[edit: my mistake, I see Telegraph Road is actually FLAC, plus there are actually MP3s in the log.]

All MP3s so far exhibit fault, tested 5 tracks, however only 1 is in log “Telegraph Road”
No FLACs so far exhibit fault, tested 3 tracks, 0 are in log
(Tracks were all taken from different albums to vary data.)

Video Player:
Don’t exhibit fault: Several Concerts of varying quality, Buffy episode 1, Core Universe Demo (0 are in log)
Exhibits fault: Doctor Who (repeatedly tested in the log between 12:00 and 12:30) - very old episode B&W.

Audio is set to passthrough 7.1.

My A/V unit doesn’t indicate any break receiving audio (screen and speaker layout display does not alter) yet it does go silent for a full second every 27 seconds.

Regrettably, you turned on debug logging just before the last of these tests and didn’t play the video for more than 27 seconds. I couldn’t see any mp3s being played while debug logging was on either. Can you reboot with debug logging on and play the problem tracks again, please?

Luckily I was just thinking how convoluted that log was so had just rebooted and made another a moment ago.

https://paste.osmc.tv/atomogeqig

Here I’ve rebooted, waited for library update to complete then gone to Video, play downloaded Doctor Who and let it play for 3 audio interruptions before stopping.

The time period of interest is 15:17:54 to 15:19:50.

I can see the 1m 17s approx in the log where it’s playing and absolutely nothing is logged :frowning:

For completeness, I copied the file to the osmc local storage and rebooted removing USB.

Played for 3 minutes, same issue every 27 seconds and not a single entry in the log for that period.

Baffled.

Try setting your GUI resolution to 1080p.

Yes that stops it for both music and TV. Weird, it worked perfectly in Leia.

Any ideas what’s causing it?

Forcing the Vero to upscale some things to 4K can cause a lot of load and it is not intended to be run this way. I would recommend you enable refresh rate switching to go along with that reduction in UI resolution. Please see the following…

We recommend people with 4K TV’s set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. *Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

3 Likes

Marvellous, thank you for all the info. I’ve set it up as recommended and will see how it goes.