Automatic master user login during boot

#1

Hi all,
can you force osmc to login into master user during boot process?
Every time after bootup up I get master user screen, which is annoying since i dont have a keyboard connected and I cant pass that screen.
tia!

#2

Do you actually use multiple accounts ? If not delete the extra ones.

#4

sorry quite a newbie at this. Can you pls elaborate how? thx!

#5

Well you must have added an extra profile - because by default there is only the master profile.

So if you don’t mean to have multiple profiles go back into profiles and delete all but the master profile.

#6

There are no other proflies excpet master user. However, im left wtih message "master user – Last login date"during bootup. I odnt want to have keyboard connectefd all the time since i have to press enter key aftet that screen and non of the kodi remote control app doesnt seem to work at this stage

#7

I’m facing the same problem here. I have not created any new profiles, but I cannot get rid of the “Master User” message in the beginning. Please let me know if I can provide some data or log that might help you.

#8

Hello, i’m facing also the same issue. I would like to remove this master user confirmation. Indeed i’m using mostly the remote control webapp on my smartphone which is not allowed until i acknoledge the master user.
Please advise.

OSMC freezes sometimes/Master User
#9

After digging a little bit in the menus Settings -> Profiles, i found that there is an auto login option. By selecting login screen it appears enlighted and after reboot the master user login disappeared. Hope it will help someone.

1 Like
#10

Just started seeing this and decided to jump on the forums. I LOVE the OSMC community. 30 seconds later, i found this post and solved my issue. Thanks @stefan_cervo!

Cheers and Merry Christmas everyone!

#11

Is there any way to remove this master user via ssh. I do not have a keyboard at all and I accidentally turned this on in the profile screen. Now access via the iOS app is locked out till I sign in.

#12

Have you tried to connect to the webinterface of Kodi to correct that?
Also now when you are in ssh there is a “remote” available on the command line. See here

#13

Got into web interface and have profiles, remote, movies etc. Going into profiles doesn’t load anything, I just get s blank screen.

Could the profile.xml be edited somehow to resolve this?

#14

Just ssh into the box and edit it .kodi/userdata/

Details regarding how to access the command line interface can be found here on our Wiki: https://osmc.tv/wiki/general/accessing-the-command-line/

#15

I would suspect it to be within .kodi/userdata/guisettings.xml

#16

Tried editing the profile.xml no change

Had a look through guisettings.xml but it’s long and I don’t know what I’m changing.

Could I copy in a complete default guisettings file? Would anyone mind pasting there file here for me? Should be ok if everything is set to default?

#17

I may just lift a keyboard from work today and just do it the easy way :slight_smile:

#18

Just

sudo systemctl stop mediacenter
mv .kodi/userdata/guisettings.xml .kodi/userdata/guisettings.xml.backup
sudo systemctl start mediacenter

#19

Ahh nice, I’ll give that a go thanks!