Autorestart at special time

How can i exit out of the journalctl?
CTRL+X doesnt work.

Shawn

Q i think it was

Q or CTRL-C works.

Alternatively, you can run systemctl status mediacenter.

Agreed. Regular reboots is a function of Windows, not Linux :slight_smile:

Seems that everything works fine, but…

One problem is still alive. Everyday i restart the mediacenter at 5 o clock and my TV turns on at this time HDMI CEC is probably the problem.
Where can i turn off the HDMI CEC Function so that the TV dont turns on by itself?

Or is there a way to ignore the HDMI CEC function while executing the command?

Many Thanks

Maybe, if you play with this file: /home/osmc/.kodi/userdata/peripheral_data/cec_CEC_Adapter.xml

Content:

<settings>
    <setting id="activate_source" value="1" />
    <setting id="button_release_delay_ms" value="0" />
    <setting id="button_repeat_rate_ms" value="0" />
    <setting id="cec_hdmi_port" value="1" />
    <setting id="cec_standby_screensaver" value="0" />
    <setting id="cec_wake_screensaver" value="0" />
    <setting id="connected_device" value="36037" />
    <setting id="device_name" value="Kodi" />
    <setting id="device_type" value="1" />
    <setting id="double_tap_timeout_ms" value="300" />
    <setting id="enabled" value="1" />
    <setting id="pause_or_stop_playback_on_deactivate" value="231" />
    <setting id="pause_playback_on_deactivate" value="0" />
    <setting id="physical_address" value="0" />
    <setting id="power_avr_on_as" value="0" />
    <setting id="send_inactive_source" value="0" />
    <setting id="standby_devices" value="231" />
    <setting id="standby_devices_advanced" value="" />
    <setting id="standby_pc_on_tv_standby" value="36028" />
    <setting id="standby_tv_on_pc_standby" value="0" />
    <setting id="tv_vendor" value="0" />
    <setting id="use_tv_menu_language" value="0" />
    <setting id="wake_devices" value="36037" />
    <setting id="wake_devices_advanced" value="" />
</settings>

Of course, do make a backup of this file before tweaking any option. Your choice for any feature is either 0 or 1.


:point_right: Alternatively, in Kodi: SettingsSystemInputPeripheralsCEC Adapter

Under CEC Adapter, you’ll see many options. The first one or the third one will probably help you.

In fact, I think this method (via Kodi) is better to fix your problem.


The Kodi wiki for CEC: CEC - Official Kodi Wiki

Also, I happened to discover by accident this thread (just in case): Ignoring CEC settings


(I’m not able to test for the moment)

1 Like