Best / fastest connection between 2 Vero 4k boxes


#21

Thanks for the posts fzinken / jzimmer. I have Vero 4k boxes, but none of the media is anywhere near that resolution. Most is 720. I may have the odd thing at 1080. The films I have range in size from 800MB to 2GB. Once the media starts playing I get zero lag or artifacts. If I am reading the iperf figures right I am able to transfer about 56Mbit/sec which is 7MB/s. The biggest film would be in the region of 2GB and 1hr 40mins. So thats 6,000 seconds and 2,000MB, which has a bandwidth requirement of way less than 1MB/s. Please let me know if I have misunderstood this. There is no lag when running the media from the box it is directly connected to, and the initial time to start playing lag seems proportional to the size of the media file when accessing it from the second box. This seems to me to be perhaps that the second box is isnt starting to play the media straight away. Is it buffering an amount of the media, or is this something to do with the connection being set up as SFTP and possible encryption overhead?

I havent been able to get the FTP connection set up because of the aforementioned messages I get and havent had a chance yet to work through the process of setting up the NFS connection; I hadnt realised I needed to install additional software on the box to achieve this.

Cheers


Failed update then black screen on reboot
#22

Would anyone have any suggestions as to why I cant set up an FTP connection between these boxes as I get the message detailed above in post 15? (Best / fastest connection between 2 Vero 4k boxes)

The FTP service is running and I can set up SFTP connection ok. Am I missing something in the set up configuration process?

Many thanks


#23

Did you select FTP source? It looks like you may have selected NFS from above.


#24

I have tried adding a source as both FTP and NFS but get the same message. I hadnt realised I needed to do more configuration to set up the NFS connection and will try that when I get a free evening. The FTP one should work out of the box shouldnt it provided the FTP server service is enabled?


#25

As an update to this one, I have ensured that the FTP service is installed from the App Store and is enabled. However, I cant seem to get the 2nd Vero 4k box to FTP to the correct location on the 1st. Specifically I am trying to get to /media/Apple TV (a throwback from when I was using an Apple TV v1 running crystalbuntu). I can log in with FTP and can see the root directory, inc /media, but I cannot go in to any of the folders. If I try connecting the FTP straight to /media/Apple TV I get a message that it Couldnt Connnet To Network Server.

I can see the box from the 2nd on on Zeroconf Browser > FTP but if I select this I get the spiing circle for a second or so and then the screen just stays on the Zeroconf Browser screen and doesnt connect to the 1st box.

I can create a connection via UPnP from the 2nd box to the 1st, but the file list doesnt look right; it doesnt put the folders at the top then the files. All the items in a folder are sorted alphabetically regardless of if those items are folders or files.

Wierdly, I can, however, FTP from my laptop to the 1st box?!?!? I have tried loggin on to the 1st box by SSH and setting the /media folder and all subdirectories to 777 as I thought this was a permissions issue, but as I can connect ok from the laptop across FTP I dont think this is the issue.

Any thoughts on where to go next to get the FTP access sorted from this 2nd box?

Thank you


#26

Are you connecting a drive called Apple TV? If not — I suggest avoiding this directory


#27

The external USB 3 drive with the media on it is called “Apple TV” and is mounted at “/media/Apple TV” on the Vero


#28

I am also able to successfully FTP from my Android phone to the box with the media USB attached. To me this indicates the problem lies on the 2nd box rather than the 1st box. I will reinstall OSMC on that 2nd box when I get a chance to see if this resolves the connection issue. Keep you posted


#29

You would be better off adding it manually (static IP if possible)

Sam


#30

Sorry Sam, I am not following you.


#31

I suggest setting static IP reservations in your router