Blank Screen on startup

Something has gone wrong - I have two Raspberry Pi 3’s both have had OSMC loaded on them and have been working fine… until today. As luck would have it, I chose to reboot both, and both go down nicely, then the blue screen with the OSMC symbol appears… and then they go to a blank screen and just sit there.

I can SSH into them, so I know the OS is running, but I’m not sure what to do.

On a lark, I pulled the sd chip from one and re-loaded OSMC on it. It came up, I did some configuration, including adding smb, rebooted, then added my first source from an smb source, rebooted, and now the same thing, blue screen w/OSMC, then blank.

What happened??? I don’t even know where to start.
thanks, Larry

Hi Larry,

Sorry to hear your having issues. We’re going to to need logs, to help diagnose the issue.

Thanks Tom.

Well, okay… but how do I find them ?

Sorry, didn’t read far enough down in the link. I did the grab-log -A -C and FTP’d to my PC, but I don’t see a way to attach a file here, and if I copy and paste it in, its too big. ???

grab-logs -A and share the URL

Logs available at

Check your MySQL server is still up.

Ya, on the one I completely re-loaded, I fill in the entry for MySQL, but I keep getting a message that the data is incomplete.

MySQL is running on my Windows PC, where do I kick it to re-start sql?

I have no clue…

In “Services” I did a restart of MySQL57. It says its running.

Hi Larry,

I think this may be your issue issue:

Setting up rbp2-image-4.4.27-9-osmc (9) ...

 Hmm. There is a symbolic link /lib/modules/4.4.27-9-osmc/build
 However, I can not read it: No such file or directory
 Therefore, I am deleting /lib/modules/4.4.27-9-osmc/build

 Hmm. The package shipped with a symbolic link /lib/modules/4.4.27-9-osmc/source
 However, I can not read the target: No such file or directory
 Therefore, I am deleting /lib/modules/4.4.27-9-osmc/source

Others will maybe able to advise otherwise, but I think a re-image rather than repair is the way forward.

Are you able to provide logs from the other one?

Thanks Tom.

That’s not an error. Headers are just packaged separately from the kernel image.


Hi Sam,

Apologies, couldn’t see it in my logs. So assumed it was an error. (I’m still learning)

@LarryM404 I’ll take another look at your logs, could do with the logs from the one where changes haven’t been made since the blank screen.

Thanks Tom.

Well, there may indeed be something up with MySQL - the logs I sent were for rpi02, which is a brand new image. On that box I attempt to set up MySQL, but even tho filling in all the entries, when I go to exit, I get a message that data is missing.

Grab-logs on rpi03, which has the original image
Logs available at

So, rpi02, not connected to MySQL, but can’t configure to it. Rpi03 is configured, but displays blank screen on re-boot. Very suspicious…

Anytime you change advancedsettings.xml, ie: add mysql info manually or by gui, you must restart Kodi to see those changes.

Hi Larry,

[ 4202.230832] FAT-fs (mmcblk0p1): Volume was not properly unmounted. Some data may be corrupt. Please run fsck

There could be corruption to boot partition, but I’m guessing this probably occurred if you’ve pulled the plug when getting the blank screens; as osmc was probably still booting.

Are you still getting the sql errors, since you’ve restarted the mysql service on windows. You’ll need to do grab-logs -A again.

If you can ssh to the other one, logs would be ideal for comparison.

Thanks Tom.

Okay! Its Windows Firewall that’s giving me grief. If I turn it off, rpi03, the existing image boots and properly shows check marks on items that have been watched.

Looking at the firewall settings I don’t see anything for MySQL.

I visited, searched for Windows Firewall and they do have instructions, but they don’t match my system. Any clues that can help me fix this???

Google more :wink:

You’re not giving us much to go on. Windows. Er, which version, for starters?

Anyway, it looks like you need to open TCP port 3306 inbound for MySQL.

With that pearl of information, all you need to do now is figure out how your Windows firewall works. (Oh, don’t look at me. I need a full biohazard suit if I’m going to go anywhere near a Windows system! :grin:)

Well, what a pain the the ol wazoo. Searching didn’t have the correct info Per suggestion google to the rescue and MS themselves have the answer. Rpi03 (orig image) now fully operational again.

The thing is tho, that rpi02, the re-imaged box, still wouldn’t accept the data. It kept saying the data was incomplete. Not sure why that would be, so I forced the issue and copied advancedsettings.xml over and voila, its up now too.

While I have your attention (and thank you for being here on Sunday!) on the re-imaged box as I was setting up, there was a choice that got the old Confluence skin. Previously (on rpi03), I had to download the Confluence screen… but these aren’t the same. On the downloaded version “My OSMC” is under “Programs”, in the old default, “My OSMC” is under “System”. Is there something I can do now to get them both on the old Confluence (my osms in settings) ??