Bluetooth dongle from the OSMC store does not work on Vero 2

Hello.

I purchased the Bluetooth dongle from the OSMC store and plugged it into my Vero 2.
After plugging it in I ran the command from the Bluetooth test post to install necessary Bluetooth software.
When finished installing, the Vero 2 restarted and hung on the OSMC startup screen. Nothing happened after an hour of showing the OSMC logo, so I re-plugged the power, and then it booted normally.
The first thing I noticed was the sound from the GUI was lagging, I then went in to settings for audio and changed from “OSMC streaming to Bluetooth speaker / headphones” to “AML-M8AUDIO, S/PDIF”, then the audio from the GUI was fine - no lagging.
Then I went into MyOSMC - Network, connected my iPhone 6s (iOS 9.3) to OSMC, everything went fine, paired with password. I then restarted the device.
Connecting my iPhone to OSMC went fine, but the sound is very sparky, and dropout all the time, it’s impossible to listen to. Tried to change back to “OSMC streaming to Bluetooth speaker / headphones” - same problem.
After a day went by I sat down to try again, first off the iPhone wont to connect to OSMC, I removed the device, and tried to connect it again - didn’t work. Then I restarted the Vero 2, and now the Bluetooth menu isn’t showing anymore, it’s gone. Have tried to use different USB port on the Vero 2 with no luck.
The dongle for the OSMC remote is plugged in the back, then on the right side furthest away I’ve plugged in my harddrive, and then the Bluetooth dongle.

I know this is testing, but since I purchased the dongle from the OSMC store and got a Vero 2 I thought it was a legit reason to make this post.
Hope you can help me out, thanks.

Log: http://paste.osmc.io/xowuxoqujo

-Andreas

What was the intended use of the bluetooth dongle ? The “Bluetooth software” you installed from the testing thread is experimental support for bluetooth audio streaming, and it is still in an experimental status for all OSMC platforms, as described in the thread itself.

Bluetooth can also be used for other purposes such as bluetooth keyboards, mice and bluetooth remotes - these functions should work fine without installing any additional software.

Audio streaming is the intended use, and yes I know this is testing, but it worked fine on the Vero.
Therefore when it didn’t work on the Vero 2 I thought I could make this post, so you could see if it’s any obvious reason for it not to work.

Anyway, as you say, keyboard and mice should work, but how would I connect those if the Bluetooth menu is missing?

If a supported bluetooth adaptor is detected the Bluetooth option in MyOSMC->Network appears automatically.

From there you can search for and pair devices. If its a device like a keyboard it will just work after pairing. If its a device that sends audio then you’ll be able to pair it but it won’t actually be able to stream audio without the software in the testing thread installed.

The Vero 2 uses a different kernel to the Vero 1, it may be that some tweaks are required to get bluetooth audio streaming working properly there - I would imagine Sam is working on this.

1 Like

Ok.

As I said, I got the Bluetooth dongle from the OSMC store, I would image this is a supported adaptor.
The Bluetooth menu also appeared when first plugging it in, but not anymore.

Can you tell from the logs why the Vero 2\OSMC doesn’t detect the Bluetooth dongle anymore?

Check that your Bluetooth dongle is inserted in a side, not rear port. If you still don’t see it in Network, then run dmesg and make sure it’s being detected.

The BT Audio streaming is extremely experimental. It was mainly developed in its early stage to evaluate demand and assess whether it’s feasible (latency, performance, etc). It will only work semi reliably with 5.1 on a Pi, and for other platforms (Vero 1, Vero 2, AppleTV), which use ALSA as the primary audio sink, it gets a bit trickier and only supports 2.0 at the moment.

We are working on improvements to Bluetooth audio streaming across all platforms. The dongle you purchased is the recommended one, so as we iron out problems in the future with Bluetooth playback, you can expect to see these improvements too

Cheers

Sam

1 Like

Ok, plugging it in and out a couple of times did the trick.

Thanks for info, looking forward to future development.

Thanks for the help @DBMandrake and @sam_nazarko.

Should this work out of the box now? I bought a vero 2 and a bluetooth dongle, and I managed to pair the vero 2 with my onkyo 265 DAB, but I can not connect to it and consequently not stream audio to it.

Audio streaming is still experimental, and it’s still in development. More information at [TESTING] Bluetooth audio streaming (A2DP).

We are making some improvements for Krypton.

I did apt-get upgrade, and then ran the command from the test thread. I ran that as user osmc, was that wrong? I can still not connect to the onkyo amplifier.

It’s still experimental, and I don’t believe it will work on the Vero 2 yet.

This command will break your system, and you should reinstall OSMC after running this. You should use apt-get dist-upgrade in future.

Still worked nicely after reboot. But I do dist-upgrade then…

Yes, but future updates will not be guaranteed to work properly or as expected until you reinstall. This has been covered quite extensively on the forum.

Keep an eye on the thread for improvements to BT audio for all platforms in the near future.

Sam

I appreciate the help! What exactly is it I need to do to recover?

You may need to reinstall OSMC. If it still works for now, you can leave it. If things become problematic when the next update is released, you can reinstall OSMC.

https://osmc.tv/wiki/vero-late-2015/reinstalling-osmc/

I have added a warning in the latest update to prevent users from doing this in the future.

Still alive after a reboot. And still not able to connect to the Onkyo amp. This time it tries, there is a spinner saying “working…” for a while, but it fails.

Please read my comments above again.

  • The commands you have run will only cause problems next time an update is released
  • Support for BT audio streaming is not yet available for this device. But you should try pairing via the command line instead.

Now I actually have succes: After a few reboots, I could actually connect to my Onkyo, and select it in the sound output section of system settings. I did the connection using the osmc gui. Very nice.

During the process the onkyo became invisible, and was not found by the bt scan until after rebooting the vero 2.

If I experience problems with updating, I will reinstall. Thanks a lot for helping, again :slight_smile:

It’s hit and miss for now as you’ve found out. The good news is we know this, and we are improving things

Sam