Bluetooth don't worki on Rpi3B+

Hi, I try to connect Bluetooth speaker and headphones on my OSMC. They work pit od the box on Libreelec on my Rpi4. I install a2dp-app-osmc but it doesn’t help. When I pair device I see notifications that pairing failed even if device is marked as paired. On system settings I don’t see option to use bluetooth as sound option. Does OSMC support onboard bluetooth from Raspberry pi 3b+?
Regards Przemek

Yes, but for the best result use a dedicated dongle

Sam

So there’s no other way to make onboard bluetooth to work?

Sure, but there will likely be dropouts. You can pair via the command line.

That onboard bluetooth is so low quality?

It has some issues, but these have been documented elsewhere.

OK, thanks. I will try usb dongle.

As @sam_nazarko wrote you might get dropouts but pairing should basically work. I would try it via command line bluetoothctl.
In terms of bluetooth as sound option, in System -> Audio it is visible as Alsa/Pulseaudio.

Hi, can You tell me how to pair on command line?
osmc@osmc:~$ bluetoothctl [NEW] Controller B8:27:EB:64:7E:13 osmc #2 [default] [NEW] Device FC:03:9F:EC:47:6D [TV] Samsung 7 Series (43) [NEW] Device 19:04:18:A9:53:7E Nillkin GO [NEW] Device E7:A7:70:B8:4A:59 Nillkin GO LE [NEW] Device 00:02:3C:5F:AC:6F SB ROAR CLASSIC LITE [NEW] Controller 00:02:5B:00:F7:86 osmc [NEW] Device 00:02:3C:5F:AC:6F SB ROAR CLASSIC LITE [bluetooth]#

agent on
scan on
pair <MAC of the device>
trust  <MAC of the device>
connect  <MAC of the device>

First I have connected yes and then connected no.
[bluetooth]# agent on Agent registered [CHG] Device 00:02:3C:5F:AC:6F Connected: yes [CHG] Device 00:02:3C:5F:AC:6F Connected: no [bluetooth]# scan on Discovery started [CHG] Controller B8:27:EB:64:7E:13 Discovering: yes [NEW] Device 60:87:CF:4C:07:89 60-87-CF-4C-07-89 [NEW] Device 00:F4:8D:77:51:DC 00-F4-8D-77-51-DC [NEW] Device 6E:E8:2B:A4:38:3A 6E-E8-2B-A4-38-3A [NEW] Device 66:6D:49:31:A1:33 66-6D-49-31-A1-33 [NEW] Device 04:91:62:20:E5:6D D1703100 [CHG] Device 00:02:3C:5F:AC:6F RSSI: -39 [CHG] Device 00:02:3C:5F:AC:6F TxPower: 4 [NEW] Device 5F:08:22:54:67:DF 5F-08-22-54-67-DF [bluetooth]# pair 00:02:3C:5F:AC:6F Attempting to pair with 00:02:3C:5F:AC:6F [CHG] Device 00:02:3C:5F:AC:6F Connected: yes [CHG] Device 00:02:3C:5F:AC:6F Paired: yes Pairing successful [CHG] Device 00:02:3C:5F:AC:6F Connected: no [CHG] Device 00:F4:8D:77:51:DC RSSI: -70 [NEW] Device F8:77:B8:1C:EA:6E F8-77-B8-1C-EA-6E [bluetooth]#
Can You tell me how to change to bluetooth USB dongle?

Your info is a bit hard to read, but I can not see that you used trust before connect?

Disable the internal one by adding dtoverlay=pi3-disable-bt to /boot/config.txt and reboot

OK, I install Libreelec and onboard bluetooth of Rpi3 work out of the box. Maybe there’s something mess up with OSMC.
Regards Przemek.

I just tested and it’s working here.
But if you prefer to use LE then that’s also fine - whatever works for you.

Hi has anyone figured out how to use the onboard bluetooth for OSMC audio? Is it a lost cause? I have a RB Pi 3, latest version of OSMC Dec 20. Keep getting Failed To Connect error both on the OSMC GUI as well as command line.

Command LIne. I did:
agent on
scan on
pair
trust
connect

[bluetooth]# connect C0:28:8D:8C:8F:BB
Attempting to connect to C0:28:8D:8C:8F:BB
Failed to connect: org.bluez.Error.Failed

Thanks!!

It’s working for me.
There is a new audio stack see below thread (you would need to remove pulseaudio if you have it installed from previous tries.).