Bluetooth fix for December update

Yeah some nice improvements but i think pulseaudio plays over kodi

What i am noticing. All my dongles seems to connect and do not disconnect.

Bluetooth stream ==> played through osmc works.

Osmc stream ==> bluetooth does not work.

Whatever i change in system settings => audio => audio output device it always plays through the HDMI.
The weird thing if i play a bluetooth stream it plays through osmc but i can start another local stream in osmc and i have now two audio which plays on top of each other.

I just tested it and version 1.1.3 of a2dp-app-osmc is working when playing audio from OSMC to an external speaker. That’s on a Pi3 with a cheapo (Cambridge Silicon Radio) external dongle. I’ll see if it works on the Pi’s internal bluetooth adapter a bit later.

The audio output device in Settings > System Settings > Audio is set to ALSA: Playback/recording through the PulseAudio sound server.

Update: Also works with the Pi3’s internal bluetooth adapter.

Latest update fixed it for me too, yay!!

Headset connected automatically, and selecting ALSA playback the audio switched immediately to the BT headset!

The noticeable difference now is that under PulseAudio there is a new item under Playback, so all is wired correctly! Great!!

I’ve done additional testing. After the first time, it doesn’t work anymore… I had to reboot, otherwise PulseAudio will not re-configure itself correctly as before. I’m still issuing a connect command through bluetoothctl to make the connection work instantly.

BTW it’s enough for now, thanks!

This is intentional.

This now works for me too Sam. Thanks so much for getting this working!

Thanks. We also have @Den4t to thank for some suggestions


1 Like

Hi Sam !

Glad I could help the project.
As far as possible, I will look at the forum,
maybe something else I can help.

1 Like

I am still not managing.

I have not managed to hear osmc ==> bluetooth

I am unable to see pacmd while osmc is on --system so cannot really troubleshoot easily

By launching it on osmc i have been able to do nexus 4 bluetooth stream => osmc => bluetooth headset so it looks like everything should be working but i am unable to hear anything from kodi

Please run grab-logs -A and maybe we’ll see something.

Right now, it looks like you’ll still need to connect manually using bluetoothctl. Make sure you’ve done that before uploading the logs.

Are you trying to use OSMC as a audio sink and audio source at the same time?

Now the April update is out. Are those bluetooth fixes included in it? Can I update without losing them?