Buffering broken with March release on 4k chapter skip?

I was responding to you. I know you fixed the buffering problem, but the lose of connection for the iPad makes it look like you have a basic network issue. Have you done iperf3 testing?

that only manifests itself when playing 4K via fstab but not when playing 4K via a Kodi mount? Can you expand? I wonder if via fstab, the Vero is “drinking from a fire hose” and gulping down more data and its wired connection is fully saturated and it’s not got anything spare to listen for pings from the iPad. As mentioned in a previous post, the network is extremely robust, serving multiple clients simultaneously without missing a beat. But if you can post instructions on how I do an iperf3 test I can look at that.

That’s exactly what I’m thinking could be happening. Do you have another remote client you could test with to see if it’s a generic problem? Just a PC connecting to the Vero web interface would be interesting.

Inspired! It’s a generic problem. I didn’t know about the web interface, loaded that from a PC with a wired connection to the common network switch, started playback of a 4K fstab file, then tried to switch playback to a different title - took about 30 secs for the Vero to respond. So nothing to do with the iPad per se.

Next thing that would prove it’s network (and not Kodi) would be to run iperf3, while doing the test again and see if iperf3 also drops.

I would need some detailed instructions.

Install iperf3 in the Vero

sudo apt install iperf3

And run it

iperf3 -s

Install iperf3 on another system (preferably one that is wired) and run it like

iperf3 -c <IP_OF_VERO> -t100 -i1

this looks pretty solid? A 20 second test.

Accepted connection from, port 58364
[ 5] local port 5201 connected to port 58365
[ ID] Interval Transfer Bandwidth
[ 5] 0.00-1.00 sec 9.68 MBytes 81.2 Mbits/sec
[ 5] 1.00-2.00 sec 11.3 MBytes 94.9 Mbits/sec
[ 5] 2.00-3.00 sec 11.3 MBytes 94.9 Mbits/sec
[ 5] 3.00-4.00 sec 11.3 MBytes 94.9 Mbits/sec
[ 5] 4.00-5.00 sec 11.3 MBytes 94.9 Mbits/sec
[ 5] 5.00-6.00 sec 11.3 MBytes 94.9 Mbits/sec
[ 5] 6.00-7.00 sec 11.3 MBytes 94.9 Mbits/sec
[ 5] 7.00-8.00 sec 11.3 MBytes 94.9 Mbits/sec
[ 5] 8.00-9.00 sec 11.3 MBytes 94.9 Mbits/sec
[ 5] 9.00-10.00 sec 11.3 MBytes 94.9 Mbits/sec
[ 5] 10.00-11.00 sec 11.3 MBytes 94.9 Mbits/sec
[ 5] 11.00-12.00 sec 11.3 MBytes 94.9 Mbits/sec
[ 5] 12.00-13.00 sec 11.4 MBytes 94.9 Mbits/sec
[ 5] 13.00-14.00 sec 11.3 MBytes 94.9 Mbits/sec
[ 5] 14.00-15.00 sec 11.3 MBytes 94.9 Mbits/sec
[ 5] 15.00-16.00 sec 11.3 MBytes 94.9 Mbits/sec
[ 5] 16.00-17.00 sec 11.3 MBytes 94.9 Mbits/sec
[ 5] 17.00-18.00 sec 11.3 MBytes 94.9 Mbits/sec
[ 5] 18.00-19.00 sec 11.3 MBytes 94.9 Mbits/sec
[ 5] 19.00-20.00 sec 11.3 MBytes 94.9 Mbits/sec
[ 5] 20.00-20.16 sec 1.84 MBytes 94.6 Mbits/sec

[ ID] Interval Transfer Bandwidth
[ 5] 0.00-20.16 sec 0.00 Bytes 0.00 bits/sec sender
[ 5] 0.00-20.16 sec 226 MBytes 94.2 Mbits/sec receiver

Looks good. Was that done while trying chapter skip? If not, do the same test, and about 10 seconds into the test try a chapter skip.

So I run iperf from the monitoring PC, while the Vero plays a file from the NAS?

Correct. Start iperf3, start movie, let play for about 10 seconds and then try a skip.

So do about a 60 second test should cover it.

Ran iperf again with an mkv playing, does not seem to be very informative. The PC and my NAS are both pushing data to the Vero and the mkv is a little juddery. I think the conclusion from this thread is that network-based remote control (via the Vero’s own web interface or an iPad) can break with 4K fstab playback. Should that be discussed in a new thread with a relevant title?

I wanted to add my feedback to this as I have noticed issues with 4K content on the Vero 4K since the latest update.

For some background, I have been using the Vero 4K for a while without any major issue. My Vero 4K is connected via WiFi (5GHz) after iperf3 tests showed that I had a better bitrate when connected via 5GHz WiFi than I did over Ethernet.

Before the recent update, I have been able to watch 4K content (usually in .mkv, h265 format) without any issue at all. Everything played perfectly and there was no buffering at all.

However, I recently wanted to watch Altered Carbon in 4K but I noticed it was buffering (showed 0% cache in the OSD), but I put this down to the video file being a standard .mkv h264 file instead of the h265 version.

Unfortunately, this is not the case.

I have some other films in h265 .mkv format (Alien Covenant, Wonder Woman, Patriots Day etc.) that are all 4K and played perfectly pre-March update. However, trying to play these files again after the March update results in buffering and stuttering playback.

To be safe, I re-ran iperf3 to see if this was a result of our new TV cabinet and placement of the Vero 4K and the results were:

Transfer: 1.40 GBytes
Bitrate: 123Mbits/sec

I left iperf3 run for at least 40 seconds and that is the average - highest bitrate was 143MBits/sec.

Unfortunately I cannot remember exactly what the stats were when I ran iperf3 before, but I seem to remember them being around 100MBits/sec, so this bitrate should be more than adequate.

I’m at work right now, but I am happy to provide additional logs / detail if needed, but everything I can see from the above indicates an issue with 4K streaming since the new update.

PPS - I have tweaked the advancedsettings.xml file to increase the level of caching too. It was the following:


And it is currently:


@sam_nazarko any suggestions would be welcomed!

EDIT: Logs uploaded for reference: https://paste.osmc.tv/lujuxusaco

EDIT 2: Updated logs uploaded after fixing the advancedsettings.xml issue: https://paste.osmc.tv/etonujubub

Can you try reverting the advancedsettings so that the OSMC settings are used?


I’ll have a go this evening and report back.

Out of curiosity, why would that make any difference? Isn’t the cache level higher in my updated advancedsettings.xml than the default OSMC one?

EDIT: @sam_nazarko, if my advancedsettings.xml was not in play, as per @dillthedog’s eagle-eye comment below, does that help?

One small - but relevent - point: your advanced settings are being ignored.

20:14:16.027 T:4080435792   ERROR: Error loading special://profile/advancedsettings.xml, no <advancedsettings> node

You need to enclose the <cache>...</cache> details within <advancedsettings>...</advancedsettings> tags.

Ok, thanks. So it would become:




1 Like

Ok, I have changed the advancedsettings.xml to use the above, but cannot test right now (my wife is watching something and I don’t want to reboot the device remotely and face her wrath) but I’ll take a look later.

I assume that because of the missing <advancedsettings> and </advancedsettings>, the settings file in use was the default OSMC one?

The only thing it might be is the dynamic bufmargin changes to fix HEVC freezes for a couple of films.