Buffering with 4k HDR File


I received my vero 4k last week.
I connected it to my synology nas via gigabit lan (vero 4k is connected to gigabit switch which is connected to a fritzbox 7590 router. the nas ist also connected to the gigabit switch). so this should be a high speed setup. BUT i get buffering all the time. tried to play a 55 GB m2ts file. Not watchable because of stutter and buffering. very disappointing. Is it even possible to play such big files via gigabit lan? or is vero 4k supposed to be connect to usb drive for big media files?

maybe i did something wrong with adding the source. i uses the zeroconfig browser to connect via SMB to the folder on my NAS. Maybe there is a better and faster way to add a source?
I used the smb share a lot with osmc on my raspi. never had probs, but the files are of course lot smaller…

I have the latest March Update 2.


Best Regards

Due to an issue there were several updates.
Try to update again and also post your kernel version.
If you want to exclude the network as an issue try to play the video from a usb stick/disk.
Check the throughput between Vero and NAS with iperf3

just use a usb/ethernet (gigabit) adapter and you could get around 300Mb speed… should be enought


I updated to the latest version. no changes.
why using an usb to ethernet adapter? doesn’t have vero 4k gigabit lan?

how do i use iperf3?


Check kernel version in system info to ensure you are actually on latest build. It should be -69

I run a Synology NAS over a wired network to the Vero and can play 4K mkv files just fine (have never tried 4K m2ts though). Couple of recommendations for you as you say you are connecting via SMB.

Step 1: go to your Synology Control Panel, File Services and then enable NFS, then configure NFS permissions for your video share. You’ll need to create an NFS rule for the share, confirm IP addresses permitted to access (or you can allow all devices with “*”), set read/write privilege and “Squash” (I find with OSMC this has to be either “Map all users to admin” or “Map root to admin”).

Step 2: add a new media path in Kodi for NFS and check that you have playback. I found playback was fine but I had one title that gave me a chapter-skip issue where the buffer could not recover before playback stuttered.

Step 3: you now know that NFS is working. Potential further steps: either re-mount the NFS share via fstab (which has much better buffer recovery after chapter skip) or get yourself a very cheap USB/ethernet adapter. Happy to post a link to the one I bought. I went for the latter option for reasons I won’t dwell on here, but fstab+NFS certainly works very well in many use cases.

Install it with sudo apt-get install iperf3 on OSMC and the respective method on your NAS.
You then can run on the NAS iperf3 -s and on OSMC iperf3 -c <IP OF NAS>