Buggy BT implementation?

So I’m using my Logitech Harmony Elite paired to the Vero 4K for Bluetooth, and it works “fine” but there are a few issues.

1.) I get double commands sent, sometimes triple. Which is annoying when scrolling through movies etc. This isn’t consistent, and it works “most” of the time. But still, I’m not sure how to fix this.

2.) If I unplug the Vero 4K for whatever reason, or reboot it - it reconnects to the Bluetooth just fine after ~5 seconds of sitting on the Vero/Kodi menus. No biggie. However, if I unplug/re-plug the Logitech Harmony Hub, the Vero will never reconnect to it on boot-up. I have to completely remove the pairing in the Network settings of the Vero 4K, and re-set it up from scratch. Very odd.

3.) After pairing the Harmony Hub, the Vero 4K gets stuck on the blue loading circle, despite being paired (I can hear the sound effects as if I’m navigating, but it’s stuck on the spinning-circle Bluetooth screen). The only fix for that is to reboot the Vero manually, I’ve found. It’s not as if I’m pairing/re-pairing the Vero 4K every day, but it’s still something that shouldn’t happen.

For reference, I have two Harmony Elites, and two Vero 4Ks, and both behave the same.

That’s indeed (partly) really strange… I’m using a Harmony Hub with my Vero as well and I’m having absolutely none of the issues (the ones which are not normal :wink:) you’re reporting. :thinking: That would let us hope that it should work and there will probably be a way to fix it. :slightly_smiling_face:

That’s absolutely normal and related to the BT handshake/the Harmony Hub… I’m using BT with my Vero and a Playstation 4. After switching from one of the two to the other, there’s also this 5 second break after the device’s video is already visible on my TV and controllable by a remote app (in both ways, so not exclusive to Vero). It’s probably needed for the Harmony Hub to re-pair to the other device. Loosing the saved pairing is probably on the Hub’s side as well, but that’s a guess.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

So, in summary:

  • activate the logging
  • reboot the OSMC device
  • reproduce the issue (in your case the double/triple commands by e.g. scrolling as long until it occurs and the pairing process you’re describing under 3.)
  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A
  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

Can you do me a favor and unplug your Harmony Hub for 5 seconds, plug it back in, and tell me if it still works with the Vero 4K?

Also, what did you add the Vero as (device name) when you paired it?

I’ll get logs at some point, too.

Just did that… The Hub was disconnected for more than 5 seconds and rebooted afterwards. After starting the Vero activity, it sat there for the mentioned 5 seconds and then worked without an issue :man_shrugging:t2:

What I did is basically what’s described here: Configure Harmony Elite + Hub with Vero 4k/Kodi - #24 by Nickelig
If you’ve configured it differently, I’d recommend trying that guide first and testing with that - ergo getting as close as possible to my setup :+1:t2:

Hmm. I added the device as “Microsoft Kodi.” Not sure that should make a difference. I’ll try the other way and see what happens.

Ok I redid it - same issues.

Interestingly, I was wrong about my first Vero 4K. It reconnects just fine to Bluetooth. My second one doesn’t. Has a red BT symbol next to Harmony Keyboard.

Is there a way to reset network settings or something?

Did you pair in the same way?
Trust and Pair might be useful.


I don’t have a Trust and Pair option. Unless you mean with a pin?

I paired the same way with both Veros. I’m at a loss. Can I reset network settings or something?

Yep, off the top of my head the settings are under /var/lib/connman.

Do I just delete something? Just trying to figure out what to do next…

You can delete the settings there, yes.
But it may actually be part of bluetoothctl.

I’ll wait for someone else to chime in or pick this up when back at my desk



Not sure how to delete since it’s permission denied. Not sure what’s going on here, anyway, but it’s really annoying me! Going to bring my working Vero up to the bedroom, and pair it there, and see if that works. Best to rule out the Harmony hub or the Vero itself…

This whole situation is so weird…

Suggest to just use bluetoothctl to first unpair and then pair and trust

What do you mean pair and trust? You mean connect with pin?

Launch bluetoothctl, trust is a separate step to pair.

Maybe we should come up with some step by step instructions for when My OSMC pairing isn’t working well.

We probably have a post somewhere. I know there’s a reconnection tutorial but it’s not really applicable here.

Quick and dirty

Thank you all for the replies. I was able to make it work (don’t ask me why) by having it pair with PIN (even though you don’t use a PIN) in the regular OSMC Network menu.

I still have the issue where you have to pull the power on the Vero after pairing since it get stuck on that loading symbol, but I’m going to guess that’s normal since both my Veros do the same thing there.

Guess the drama is over… for now.

As I had to repair just recently (the Hub somehow forgot the Vero), I can assure you that this is not normal. The pairing here has always worked without any hanging in the busy screen or any other step than pair without PIN.

And you’re using an Elite? Not sure what to tell you then. My second Vero behaved right out of the box the same way as the first in this regard. Both don’t “hang” but I can’t get away from the loading symbol. I can hear the sound effects of menu changes, but I can’t get those menus to take focus. So I have to pull the plug.

Either way it’s not a huge deal since I should only ever see that issue when I pair a new BT device, which should be never. :smiley: