Cannot access NAS after IP address change

Hello, I recently needed to install a new router which necessitated moving my NAS from 192.168.0.1 to 192.168.0.100 (new router reserved 192.168.0.1). All works as it should except the Vero4K. I get a message of “Error - File Exists” when I click on the menu to access the NAS files. I also get a message of “Remote Share - Could not connect to network server”. The NAS name, on the network did not change. I have been through every file I can seem to access and cannot see anything wrong nor any IP address settings e.g. :-
MediaSources.xml
mediasources>
network>
location id=“2”>smb://homebackup/tv shows/location>
location id=“3”>smb://maindesk/tv shows/location>
location id=“2”>smb://maindesk/movies/location>
location id=“3”>smb://homebackup/movies/location>
network>
mediasources>

The “maindesk” is a PC with a shared drive and that is accessible with no issues.
The “homebackup” is the NAS that I am having problems accessing.
The NAS is accessible, with no issues, from the rest of the network… only the Vero4K
has a problem.

I have spent ages trying to solve this no no avail.
I am obviously missing something (wrt to knowledge).
Help please.

Are you actually using the IP address of homebackup or are you using this name of the networked device?

I am using the name.
I had not thought of replacing the name with the IP address.
However, although I can view the MediaSources.xml file I cannot seem to edit it.
Thanks.

The file should be sources.xml. I’m not sure why you keep referring to it as MediaSources.xml…

Sorry, my level of knowledge is the issue.
I can see the sources.xml file
Not sure how I can post the contents here.
To my eye it looks OK.
The NAS is identified as homebackup and not as the IP address.
I did try to add a video source by defining the IP address but that came up with a message that the network location could not be found… most likely due to my error with syntax ?

The simplest approach is to post everything.

Run grab-logs -A (with a big A) from the command line and let us know the URL it returns

How do I get to the command line (I’ve had the Vero4K for many years and cannot recall)…

You can provide logs from MyOSMC if you prefer. (Remember to select all options.)

As to accessing the command line, https://osmc.tv/wiki/general/accessing-the-command-line

Thanks, the URL is:-
https://paste.osmc.tv/usiliyapar

I would just do a path substitution to the ip address

    <from pathversion="1">smb://homebackup/</from>
    <to pathversion="1">smb://192.168.0.100/</to>

As explained in this how to article…

OK, I typed the line:-
nano ~/.kodi/userdata/advancedsettings.xml
and entered:-
advancedsettings>
pathsubstitution>
substitute>
from pathversion=“1”>smb://homebackup/
to pathversion=“1”>smb://192.168.0.100/
/substitute>
/pathsubstitution>
/advancedsettings>

Note that a left pointing arrow, above, causes the following text not to be displayed but is correct on the terminal screen.

I cannot see how I save that to the advancedsettings.xml

You can select the xml code and press the “</>” on the editing bar to display the code for future reference.

To save the file and exit nano you hold down ctrl and press “x”, then a prompt shows up at the bottom of the screen and you press “y” and then “enter”. You will need to reboot for the change to take effect.

Looks like I did all that but no joy…
See https://paste.osmc.tv/ofoqoziqiz

I can see the advancedsettings.xlm stuff in there but still not access to Homebackup.

The good news is the substitution is working…

SMBDirectory->GetDirectory: Unable to open directory : 'smb://192.168.0.100/movies'
                                            unix_err:'11' error : 'File exists'

But I think that maybe your NAS is refusing the connection. I would check that as it might need some kind of a permission setting changed there. Maybe also check to make sure you can see the NAS at all by (via ssh) typing ping 192.168.0.100

A quick search showns that you’re not the only one who has had this problem.

This might be a solution: Accessing SMB share: "File exists" / "Operation not permitted" errors

1 Like

Thanks, the ping is successful.
I will investigate further tomorrow.
Is 2:40am here and I need a few winks of sleep before getting for work later this morning.

Thanks for all your help thus far… good night from my end

1 Like

BTW, how do I stop the ping from repeating continuously ?

Ctrl-C

Thanks, sorry, UNIX is alien to me.

Best Regards.

Also see this…

Good thing you’re using Linux then :grin: