Cannot connect to WiFi

My Vero4k+ can see WiFi networks in the area, and has been connected to mine just fine for the last 9 months in its current location but yesterday i noticed it was not connected to a network and when going into My OSMC it shows all networks in my local area with the pink “x” next to them with the status “no wireless connection” and on the rare occasion it will connect to mine it will say “no internet”. I was using a static LAN IP, but have also tried DHCP (cant switch while there is no connection as it throws an error).
Connecting with cable works fine. I was on version 11-2, but have just upgraded to 12-1 but that hasnt fixed it.
My WiFi signal strength is -66dB, which while not perfect, is good enough and has been fine all these months at a strength in that area. There are only a couple WiFi networks within distance and mine is currently the only one on channel 1, so interference should not be the cause. The other networks have worse signal strength too.
Is is worth collecting logs? I cant see it being as there isnt really an error, just that it doesnt connect.
Is there anything i can do as leaving an ethernet cable connected is not an option. Getting a powerline adapter may be an option in the future but hoping to solve the WiFi problem if i can.

Most likely this issue which will be fixed in the next version.

I did see that and wasnt sure if it was related to my problem, but having changed my 5GHz channel to 48 i can see and connect to my 5GHz network. Still nothing on my 2.4GHz network though. I was set to “auto” channel on my 5GHz network and the area around 36-48 is a bit congested with nothing around 100 channel which is why it was on that.
However, i cannot edit the IP address if i want to set a static IP but this is probably another issue. It was editable before the 12-1 update but now i cannot move to select any numbers or anything but “done” on the IP editing page.

For now im connected to 5GHz using DHCP and it works so i’ll wait for the next update.

A photo may help

Hi Sam,
Sorry i’ve not been around much since posting this. A photo wont really show anything as its just the normal IP screen but i cant move around the screen to change the IP, the only think i can do is press “done” which is already highlighted. I havent tried again since as i’ve only used the box once since then and i had WiFi issues again but i disconnected from WiFi/reboot/reconnected to my SiFi network and that worked this time.


There I think the skin in staging would probably fix this issue, this is what I did. From the commandline

echo 'deb buster-devel main' | sudo tee /etc/apt/sources.list.d/osmc-devel.list

sudo apt-get update && sudo apt-get install mediacenter-skin-osmc && reboot

I suggest deactivating (will do automatically after 14 days) the staging repo once the system restarts:

sudo rm /etc/apt/sources.list.d/osmc-devel.list

Also optional to make sure the correct repo’s are synced: sudo apt-get update

Thanks Tom.