Cannot Enable HDR on Settings

Hi Everyone.
I’ve been trying to read the forums but I can’t seem to find the menu where HDR can be enabled on the
Vero 4K+.
Pressing the HOME button on the remote and selecting Settings don’t have any option on HDR.
Please help. Thank you.

I guess you misunderstood the other thread where you read that.
That was the instructions how to enable HDR on a Sony TV.
The Vero will automatically sent HDR Data if a HDR file is being played and the TV indicates that it supports HDR.

Edit: as @MTV points out Adjust Refresh Rate should be set to Always or Start/Stop for resolution switch to work.

did you enter the expert menu?

  • Resolution set to 1080p
  • Adjust Refresh Rate set to Always

just set this and all files above 1080p will be played “automatically” in the correct format.

Also be sure that your tv/avr is set the mode that allow in passthrough HDR. or enable HDR.

for example samsung current models needs to enable UHD Color on
for example denon receivers needs to set 4k enhanced

Thank you for pointing it out.
I was thinking that there’s a separate option when I saw this post

“On the supplied remote control, press the HOME button.
Select Settings.
Under the TV category, select External Inputs.
Select HDMI signal format.
Select the appropriate HDMI input.
Select Enhanced format.”

Since all of my 4K HDR Files have WASHED OUT Colors, I thought there might be an issue
with my HDR settings on the VERO 4K+.
Right now, I just turned off HDR on my Sony X900E and the colors are better than HDR Enabled.

did you set colors to limited or full?

Use limited colour range (16-235)

please provide from ssh:

cat /sys/class/amhdmitx/amhdmitx0/config

see also this HDR not working properly after April Update (Vero 4K+) - #12 by nabsltd

also Sony X900E Calibration Settings - for this:
In the ‘Video options’, just verify that ‘HDR mode’, ‘HDMI video range’ and ‘Color space’ are set to ‘Auto’ and it should change automatically to match the type of content you are watching, in this case, HDR content.