Can't access via samba - SOLVED

So far so good wuth the osmc on my pi2

Only issue so far is the inability to access it via samba from es explorer. It finds all my other pi but not this one.

Also using the ui to allocate sources to samba is also very flaky. .i know this is a kodi issue of old but wondering if they might be linked this time.

But hey this boy whizzes! !!!

1 Like

Make sure you use IP addresses for your Samba shares rather than hostnames, as hostname resolution is indeed flakey.

Good p point I’ll try that.

Not sure why es explorer on my phone won’t find the pi though. … No problem with my other 2pi

Samba server has not been added to OSMC yet.

Of course! Did read that somewhere and forgot.

Ftp for the time being then :relaxed:

If that is so, why do I have /etc/samba/smb.conf? Is there a reason to not apt-get install…

Hi I have Raspberry Pi 2 Model B and OSMC_TGT_rbp2_20150315.img, and I do not know to add samba drives. In XMBC it were, you know how to proceed in this problem?

You can do this from My OSMC -> App Store

Which application should be downloaded from the App Store ? (Now I do not have access to raspberry)

Sorry, I misread your question

I thought you wanted the Samba (SMB) Server app.

To add Samba shares you can do it via the Context Menu -> Add Source


Ok I’ll try it (I have about this option in the menu overlooked) in XMBC I found it , but at OSMC I have not found this option…

Running OSMC on a new Pi 2. I can access a SMB Share from my Pi to a shared drive on my Windows 7 PC. I however cannot see my Pi in Windows 7 when I open Networks In Windows. I see my other shared devices including Openelec and older Raspmc but I dont see my OSMC out on the network.

Any ideas?

Have you installed Samba server on OSMC? It’s not installed by default

No, I have not. I didnt have to do anything on Openelec nor Raspbmc. Where would I get Samba server to install on OSMC?

Look for the shopping cart icon in the MyOSMC settings addon.

I got the Samba server installed in OSMC. Looks good now

1 Like

Many thanks to ActionA this was most helpful. I thought I was going to have to do a manual install through puTTY
Bit daunting when not a linux person.

Cheers … Bob :smile:

smb doesn’t work