Can't get subtitles to appear (Alpha 2)

Anyone else having issues getting subtitles to show up?

No issues did you actived your subtitle (new popup menu)

Yep, subtitles are enabled.
In the audio settings menu, the “Subtitle” setting below Subtitle Offset is grayed out. Not sure what that means.

They’re ssa / ass subtitles.
Googling around I see some old posts about xbmc having issues with them, but it used to work when I was using raspbmc.

Just reinstalled raspbmc and the subtitles work fine. So it’s only osmc.

Same Problem here with Alpa 4.
Other Subtitles work well only SSA/AAS seems not do be displayed. The Subtitles are detected and I can choose different Subtitles but as soon as the subtitles are SSA/AAS nothing is renedered.
A bit of googeling found not much regarding this problem. A similar problem seemed to exist with Kodi 14 Alpa five moths ago were it came from changes in how ffmpeg 2.4 handeled SSA/AAS ( ). Maybe this is related?

Otherwise my migration from Rasbmc to OSMC went smoothly. Thanks for all the great work on this project.


No issue on raspbmc. On osmc it shows a susbtitle in the subtitle offset but its in red and no subs are shown.

Had the same problems with SSA/AAS subtitles. After some trial and error I managed to get them working by running

sudo apt-get install libass5
1 Like

Thanks for reporting this. We’ll make sure this library is included in the next Alpha.

Nice one

Here testing Alpha 4, and I don’t know why, but installing libass5 was not enough for me to see some of the subtitles inside MKV files (mainly from Anime releases). However, doing

sudo apt-get install libass-dev

worked perfectly. Maybe a little overkill?

I have been having trouble with this same issue. I opened up the console and tried both @SimonO and @MYKSelf codes.

Both of them give me the same error, stating it is unable to find libass. Can anyone help me?

Have you run sudo apt-get update ?

Currently Running:

sudo apt-get update sudo apt-get upgrade sudo apt-get dist-upgrade

then I will try again with:
sudo apt-get install libass-dev

Thank you for pointing that out, I have very little experience with Linux systems. I had a RasPi B running XBMC and never had to really do much in the way of console code. I just got my Raspi B2 in the mail today and finding that XBMC is discontinued I came here to OSMC.

@SimonO Thanks for the help, the problem’s solved now ^^

Hello… I’m also new to this… When I try to make that command (sudo apt-get install libass5) in my terminal to Openelec I get the following reply.

There is no working ‘sudo’.

On debian/ubuntu/all general purpose linux distributions ‘sudo’
allows a permitted user to execute a command as the superuser
or another user, as specified by the security policy

With OpenELEC you have root access by default, so you dont need ‘sudo’

VERY informate but also very confusing… I’m guessing you guys control your media station in some other way. Care to tell me how?

Thanks in advance…

You need to install OSMC to get apt-get. Check out



This is the OSMC forum not the OpenElec forum.

The apt-get commands listed above were for OSMC and have no relevance to OpenElec, which doesn’t have an apt-get command let alone a sudo command.

I suggest you install the OSMC RC and give it a try…

The fix above for subtitles is not needed in the RC btw, these missing libraries have been fixed.

Hehe thanks guys… I’m so new to this… having a hard time just keeping all the different OSs apart ;)…

Thanks. I will try this one instead of openelec then =)…

Hello there, first post here, just created account :smile:
I previously used raspbmc, recently downloaded osmc, I didn’t believe it but it is better and faster, great job :smiley:

Everything went great, except I had the same “subtitles not showing” problem that everyone was talking about.

tried apt-get update as suggested but the following error appeared:

E: Package ‘libass5’ has no installation candidate

I run apt-get update again after upgrade, dist-upgrade and reboot
Then package installed just fine and as expected the ass/ssa subtitles are showing again!

Thank you very much for your hard work, it is being appreciated :smile:

Are you sure you installed the RC release ? libass5 should already be installed…

It sounds like you have installed an older release. BTW you are posting into a thread discussion a problem in Alpha 2 - which is a very old release now.

If you still have the same problem in the Release Candidate version, please start a new thread for the problem and let us know whether you have a Pi 1 or Pi 2.

Sorry, I just saw this and another thread about not showing subtitles in mkv files but sam nazarko pointed some user to this thread about 3 days ago. Here is said thread:

True, I was on alpha 4, did not know about RC release.
I will do a fresh install today as suggested elsewhere, thanks for pointing it out!

Thanks DBMandrake!