Can't ssh into RasPi 3 with osmc


I misunderstood your first post. I thought you were trying to force putty from Ubuntu, which kinda works via wine, but not well

While this is totally offtopic to this thread I would like to avoid strange statements to remain.
AFAIK there is a native linux port of putty, from the putty manpage:

putty(1)                                 PuTTY tool suite                                putty(1)

       putty - GUI SSH, Telnet and Rlogin client for X

       putty [ options ] [ host ]

       putty  is a graphical SSH, Telnet and Rlogin client for X. It is a direct port of the Win‐
       dows SSH client of the same name.
1 Like

@tobias, what happens if you try ssh -v osmc@kodi.local (replace kodi.local with the IP of the Pi)

You will gets lots of nice details about what is happening with the -v option, And you can add additional -v options to get even more info, i.e. ssh -v -v osmc@kodi.local

If I’m reading you correctly this is similar to a problem I had, only with my PI3’s. I’m not sure, but it is whenever I connect through a particular brand of router. My home router is ok, but visit family with this brand of router and I cannot connect without this trick.

The solution in OSMC or Raspbian is the same, at least for me:

sudo nano /etc/ssh/sshd_config
IPQoS cs0 cs0

sudo service ssh restart



That actually solved my SSH problem.

Thank you for sharing :slight_smile:

If that worked, the problem is with your router having a buggy quality of service implementation:

The above settings should only be considered a workaround, and it’s likely that some other types of traffic are affected by your routers bug.

Seems to be something with the chip used in RPI3. The routers have worked just fine for all connections for about 8 years, but not the RPI3 strangely.

Thus the router thing is my observation:

I have 4 RPI3 now and they work in about 10 or more different locations, presumably with different routers - hotels, homes, and businesses (probably more than10 actually). But at these 3 places where my family signed up with the same sip they sent the same router, and that is the only time I have this problem.

Which ISP and what router are they supplying? I have seen some weird stuff with Huawei routers.

As it turns out, they are now on various ISP

In this case it’s Netgear routers involved on each occasion. Two were a DG834GV. Not sure of the other model.

But the fix above has always worked for me first time.


I was extremely glad I found this thread when having problems with SSH over Wifi on RPi3.
I had tried all sorts of checking of routing and pings without anything showing up to suggest a solution.
After reading this, I tried first the ethernet connection (which worked), and then resetting the keys (which gave no change - but I didn’t expect it to), and finally the IPQoS line added to the sshd_config file (which did give me a working system).
I had had suspicions about the router (to which I changed fairly recently, after even greater problems with my previous router) which is a TP-LINK TD-W9970.

An added quirk: I tried Ubuntu-Mate for the Pi on my RPi3, in the same location, and using the same Wifi setup.
SSH connection was immediately available, with no problems, and the sshd_config file looks identical to the unmodified OSMC version (ie no IPQoS mod)

dpkg -l | grep openssh-server on both boxes will probably show that Ubuntu Mate is running a newer version of the OpenSSH server which may have workarounds for this issue.

OSMC: 6.7p1-5+deb8u3
UbMate: 7.2p2-4ubuntu1

A query which has popped up a number of times:
Can I get a version of vi which has the facilities I got used to
eg :r! command to get results from
or have I been missing something?

sudo apt-get install vim