CEC Options missing in settings menu

I run TVHeadend TV server on my Pi3 with latest OSMC.
The Pi3 is connected to TV and AMP via HDMI.
I use the Pi3 as well as several other Kodi clients in my house to watch TV.

When I put the TV on Standby, I would like to stop media playback on the Pi3 to free the TVHeadend DVB-S adapter for other clients.

However, in the Kodi Settings/System/Device/CEC-Adapter menu, I can only choose “Ignore” “Standby” or “Switch off” as option during CEC TV Standby event.
The menu settings “Pause Playback” and “Stop Playback” are missing in this OSMC install.

Is there any way to enable “Stop Playback” item during CEC Standby Event ?

Do you have the settings level set to Advanced or Expert?


I already use the expert setting level.

I was able to make the settings appear by editing /usr/share/kodi/system/peripherals.xml

according to this post, values 36043 and 36044 need to be added.