Chapter skip broken since March 2022 update (only mkvs with Atmos/DTS-X audio affected)

While there was a confirmed chapter-skip bug for TrueHD audio when output to PCM/AC3 in 19.x, I’ve found this to be fixed in 20.x. I just tried very hard to break chapter/bookmark skipping for DTS:X and Atmos and failed to do so. I tried passthrough, full channel PCM, 2.0 PCM downmix and AC-3 conversion. Can you name a title that is causing problems? I might have it in my library.

Hi guys, I did some more tests today and want to share the (weird) results:

  1. Not all mkvs with Atmos audiotrack do show the issue, just about 50%. However, there is no systematic pattern regarding the makemkv version that was used - some mkvs ripped with same version are ok, others are not (versions tested: 1.12.2 - 1.16.7)
  2. When issue shows, only specific chapters are affected, sometimes just 1, sometimes up to 4
  3. When you skip to these problematic chapters, video freezes, Time counter resets to 0:00 but when you quickly skip to next chapter again on the remote, it will resume playback on that next chapter.
  4. If the mkv contains both, Atmos track and non-Atmos track, e.g. DTS-HD or AC3, when switching to this non-Atmos audio track, there is no issue with chapter skip!
  5. When I switch off pass-through in Kodi audio settings, the issue does no more show either even on Atmos audio track!
  6. Now it becomes really weird: Same mkv file played either via SMB or from USB stick shows the issue in different characteristics - 3 chapters broken when played via SMB, just 2 out of the 3 when played from USB stick
  7. Seems the issue is no more present for mkv with DTS-X - however, not sure that I tried the same mkv a couple of month ago

Examples showing the issue: Roger Waters US+Them (chapters 4,7,8,10), A Quiet Place 1 (3,12,15)

Are these videos ripped by yourself or are they remuxes?

This is why we really need a sample.

Also are you skipping frequently, or occasionally? I.e. are you trying to cycle through chapters very fast?


All direct output of makemkv rips. Issue shows when cycling through chapters sequentially and also when skipping to the chapters via Bookmark. Doesn’t matter how fast I am cycling. For both variants, same chapters are affected.

Regarding sample: Wondering if this will work - I would expect that a clip of original video won’t show the issue. Do you have a recommendation how to prepare a sample?

Just a trimmed / shorter clip would do. The smaller the clip, the better.


So a few seconds before and after a chapter position that shows the issue? Which tool to use? Avidemux? I assume I have to avoid any remuxing? What about the chapter info? I guess it will be lost in the short clip?


@sam_nazarko ok, I’ve created a 20sec clip with mkvtoolnix - where can I upload it to. I read it should be possible from within “my OSMC account” - I can create a ticket in there but will it let me upload a file after creation? Please advise. Thanks!

You can upload it to a platform like Dropbox

ok, done, I sent you a private message with the details.

@sam_nazarko Hi Sam, did you have a chance to look at the clip I sent you via private message? If yes, was it of any help to narrow down the issue? Thanks!

Sorry - I can’t receive files via PM. It’s important to share with the whole team so it can be tested properly.

@frank.lautenbach If you don’t have any other way to upload a clip, then using works quite well. (So long as you don’t go over the 2GB limit).