Choppy video since Krypton update on Vero 1

Same bad experience here watching choppy videos with the vero1. Looks like every 1/2 - 1 seconds some frames are missing.
Here an example which was encoded with constant 23,976 fps. While play with debugging active the onscreen debug information shows around 18-19 fps rate, only.

debug log:

A Raspberry Pi 2 with same OSMC version plays fine (but only DTS core). This Pi is my only working fallback device at the moment … :frowning:

On screen FPS is not meant to match the video playback.

Do you need another sample Sam?

Not at this time. I need to look at what has regressed in Kodi.

1 Like

Perhaps I can shed some more light to this ugly symptom.
Scanning through some videos I can derive a fix rule:

ALL videos with a resolution near 1920 x 1080 are affected with the vero1.
ALL videos with lower resolutions like 1920 x 800 are NOT affected with the vero1.

I also stripped off the audio tracks but these do not have any effects: Videos with 1920 x 1080 or similiar resolution are choppy/show the surge like missing frames.

Does this help a bit?

1 Like

It seems that there were some regressions with VideoPlayer and some videos are not playing as expected. It is being worked on.

I know its hard to give an ETA for the fix but is there anything on the horizon? I do not want to sound ungrateful but my only media player is not really usable at the moment. If its going to be like this for a couple more days then i would rather just know and do a clean install of a previous version.

I will try and identify the problem later today.
We would then need to do some testing, so it would be more than a couple of days.


Thanks alot for the fast response!

Hi, is there a link which describes how to downgrade the vero1 to the last state before Kodi Krypton release? The last version was perfect since the video core-functions worked error-free: DTS-HD and TrueHD in passthrough mode, all resolutions and frequencies without surging.
Here the family acceptance factor went against 0 for the vero since all tv recordings are affected by the surge issue. It is hard to defend the vero where the Pi platform runs like a champ.
I already own a vero2 which is not able play DTS-HD/TrueHD in passthrough and failed to win the interest of my family… and now even the first osmc flagship vero1 starts sinking? Sorry, but I get somewhat frustrated. Let me know if you need volunteers for tests. Thx for all the work.

1 Like

I am sorry to hear about the problems.

Not really.

Kodi Krypton has some regressions, as you may have seen. I am working to address these problems. It’s still a supported device. We will resolve the issue.

For now, downgrading is a bit tricky, but you can download a January or earlier image from the Download page.

I’ll let you know when we have something to test (soon).


I am on Raspberry pi 1 B, i am having same problem, choppy video with 1080 videos. The cpu usage is 100% when video is playing and its very broken.

I can upload the logs and/or create a new thread if you say…

Yes, both.

Different hardware means a new thread is needed

Is there an update for the ETA on the fix for the Vero ?

Hi – I am hoping for this weekend.

I don’t like to give timeframes however until I have worked things out thoroughly, but rest assured it’s being looked at



Looking forward to a fix :slight_smile:

Hi Sam,

Same issue with Vero 1 here too. Random buffer icon when playing 1080p, stops, most of the time sound plays but video stops, once or twice a week a sad face. Choppy/Judder video on 1080p. 720p is fine. Load never exceeds 30 percent, loads of free mem. Also still need to set ethtool to 100 autoneg. If not 1080p wil almost not play. Crashing about 2 - 3 times a night.

Sometimes it plays the same file fine, other times it crashes. Crashes faster after skipping forward multiple times.

Screensaver turns on, then after a few seconds turns off. Complete clean install of 2017-02.2.

When using this “editor” to type this image Safari uses significant energy.

The kindest regards,

Duncan, The Netherlands.

Hi Duncan,

No problem, it’s being looked at and when I have some news I’ll let you know.

Are you saying that there’s a problem with the OSMC forum? What device are you using?


Hi Sam,

Thanks again. Still waiting to pre-order the Vero 3, haha.

I use a MacBook Pro 2015. When using Google load 0-2 in battery activity modus. When opening this onsite “text editor” 8 - 28. Might be normal. But Last time we had a discussion I had multiple windows open and my MacBook got warm and noisy. That never happens, unless I’am gaming.

Kind regards,