Codec Supported by Vero4K

I believe the people who might be able to answer why your having an issue would need a bit more info. You can open a clip at to get more detailed information on the video clip. If you then press the “paste” button it will upload that info to a OSMC paste file that you can share in this thread (or you could just copy and paste the output from that page directly).

1 Like

Thank you :slight_smile:

Format : MPEG-4
Format profile : Base Media
Codec ID : isom (isom/iso2/mp41)
File size : 616 MiB
Duration : 42 s 293 ms
Overall bit rate : 122 Mb/s
Encoded date : UTC 2020-11-23 12:57:05
Tagged date : UTC 2020-11-23 12:57:05
Writing application : Lavf56.15.102

ID : 1
Format : HEVC
Format/Info : High Efficiency Video Coding
Format profile : Main@L5.1@Main
Codec ID : hvc1
Codec ID/Info : High Efficiency Video Coding
Duration : 42 s 293 ms
Bit rate : 122 Mb/s
Width : 3 840 pixels
Height : 2 160 pixels
Display aspect ratio : 16:9
Frame rate mode : Constant
Frame rate : 59.940 (60000/1001) FPS
Original frame rate : 59.000 FPS
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Bits/(Pixel*Frame) : 0.246
Stream size : 616 MiB (100%)
Encoded date : UTC 2020-11-23 12:57:05
Tagged date : UTC 2020-11-23 12:57:05
Codec configuration box : hvcC

Can you upload a Kodi debug log and sample of the file?


not an osmc but a kodi log ? yes?

I’ll try and cut it down to a size thats a sample without losing any of the info/config for it.


A full set of logs via OSMC


1 Like

Cut down video here : pCloud (the link will try to play it in a browser but you can download it (112mb) )

Logs :


Set the UI to 1080p and enable Adjust Refresh Rate.

1 Like

Tried Adjust Refresh rate (from Kodi/Settings/Player ) on its own - no change
Set UI - I struggled to find exactly what you meant by this so I changed Kodi/Settings/System/Display Mode Resolution to 1920x1080 (tbh also tried various others) but it made no difference to playback.

thanks again

You have to set both of those settings at the same time. The adjust refresh rate on start/stop allows the Vero to switch to optimal resolution and frame rates. The UI also needs to be FullHD resolution or lower otherwise it screws up the mode switching. With the settings in the log you posted everything played is fixed at 4K 24fps. Asking any player to rescale from 3840x2160 to 4096x2160 and resample it from 60fps to 24fps on a file coming in at 122Mb/s… it is a very tall ask. With those settings changes resizing and resampling don’t have to happen (plus you get improved quality output).

1 Like

i had both of those set at the same time - assuming i set the UI (UI didnt offer 1080p as an option btw) in the right place? I may be being thick here though but have I changed the UI in the right place?

The recommended settings are outlined below. If the problem remains then new debug logs taken after playback of this file with the new settings would be advantageous.

We recommend people with 4K TV’s set their user interface (UI) to 1080p. Kodi’s UI is not optimized for 4K yet and this can put unnecessary demands on your device and can lead to a suboptimal picture quality, as well as potentially cause other issues.

The settings we recommend are as follows…

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. *Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

1 Like

Looking at the log, it seems that the problem file is located at /mnt/HomeMovies/Drone/DJI/2020-Nov 23/DJI_0020.MP4, which is a CIFS share on a separate server. Access to this 122 Mbits/sec file is via 5 GHz WiFi on channel 36. WiFi can be a relatively unreliable medium and the wlan0 interface in this case seems to have a fairly large number of dropped packets:

wlan0: flags=-28605<UP,BROADCAST,RUNNING,MULTICAST,DYNAMIC>  mtu 1500
        inet  netmask  broadcast
        ether 10:d0:7a:b2:6e:80  txqueuelen 1000  (Ethernet)
        RX packets 8355600  bytes 12341602240 (11.4 GiB)
        RX errors 0  dropped 26715  overruns 0  frame 0
        TX packets 4349364  bytes 292612076 (279.0 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

I’ve not seen it mentioned on this thread, so have you tried copying the file to local eMMC storage and playing it from there?

1 Like

I have considered moving it but all the other 4k media I have (24fps) plays fine … plus moving it isnt an option on a longer term.

This is also sitting about 12 foot from a high spec Netgear Gaming router and getting pretty much max wifi bandwidth to it …

It may be a factor so I am not writing it off as a fix but first i should ensure OSMC/Kodi is optimised …


Moving it will test whether the problem lies with the network connection. There is little point trying Kodi settings if the network isn’t working correctly.

1 Like

not dismissing it - I am simply going through 1 thing at a time to tick them off the list rather than changing several things and being usure which one’s if any made a difference.

As i said up until now the wifi hasnt been an issue (nor has Kodi) playing 4k - the only difference so far seems to be frame rate and yes I agree it might be maxing out the wifi but for me its quite a major change to not use wifi from a logistics point of view (cable runs etc if we go wired and/or relocation of routers) . I will look at that next though …cheers

Anyway I have made the relevant changes to Kodi - Not sure what can be seen in the logs but I initially played a 24fp 4k movie and it played fine , then played the 60fps version and again it stutters …

Log file is here :

@dillthedog yep it was indeed the wifi - just couldnt push through enough at 60fps yet at 24fps it was fine. I ran a cable from OSMC to the router direct - unsightly but effective.

I now need to work out a way to either sort out the dropouts (no idea what other than surrounding interference which I can prob do not a lot about) and mess about with channels .

At least I know OSMC/KODI is optimised and thanks to your support we have identieid the root cause .

Resolution should be fun… thank you


Curious/confirmation. Is there any further reading on this or is it just a ‘known thing’ as I sorta figured this out myself when setting up my vero 4k+ with my LG oled. To avoid a black screen I found I needed both a resolution and framerate change on playback, haven’t had one this year.

Hard to speculate from just that.

Further information other than what is scattered across the forum? Not that i’m aware of. @grahamh has posted some details about this in the past I believe but I honestly couldn’t tell you what to search for to aid discovery. My understanding is that basically because of the way Kodi is programed with the non-whitelist auto framerate switching it does not work correctly and a fix would not be trivial. Due to limits on currently supported hardware combined with Kodi itself not being optimized for such a high resolution UI we wouldn’t recommend the UI being run at 4K and thus if a fix was made it would suck up development time with little benefit to the users. The switching does work if you use whitelists and @angry.sardine wrote a helpful guide for that in our how-to section of the forum.

As for the blank screen any particular TV has only certain modes it can operate in. Normally stock OSMC detects these and does not allow output to an unsupported format. On occasions the information from the display becomes missing, corrupt, incorrect, insufficient, etc. and issues arise. When it does there is almost always a tweak that can be done to rectify it on a case by case basis.

1 Like

Whatever it was it must have been patched a long time ago as I haven’t encountered it in a long, long time. I just remember it alongside the troubles I had getting everything working properly due to not knowing enough about hdr, new kodi box, first 4k tv (lg). I spent hours ssh into the shell querying the hdmi output on various kodi and tv settings and playing various videos. Every time I got a blank screen followed by a no signal message my heart sank a bit more.

All I remember is I finally figured out how to reliably enable switching to 4k24 4:4:4 hdmi link for hdr films and it’s been great ever since.

1 Like