Completely new to linux

I have trudged through this community up and down, and for the life of me I can not figure out how to make files viewable on the vero, which is on my desktop… what makes it more mysterious is:

  1. upnp sees em
    2.I can FTP into Vero just fine

rest…no idea…I’ve looked guides up and down

It’s like there is some steps which are omitted as theyre probably a OBVIOUS thing to the rest of people. But not to me T_T

Is there a teaspoon guide from “switching the vero on till success” somewhere ?

What exactly are you trying to do, access files that are located on a Windows 10 PC on a Vero via FTP, UPnP, or you don’t care as long as it works? Or are you trying to go the other way and you have files on a Vero that you want to access over the network from a Windows computer. If you can outline exactly what you have and what you want to accomplish then we can more effectively direct you to the information your after.

Thank you for replying.
I am trying to access files that are located on a windows 10 pc.
If I include them in windows 10 library they appear on the vero and I can ftp into vero, from my limited knowledge,that means there is contact.
But I can’t make the 3 harddrives appear.

What I have:
1 Vero 4k+
1 Desktop Pc, windows 10 version. with all my media files on
A router

What I want to accomplish:

Connect the vero to our tv, switch it on, be able to access and select the files through the network,select the one i want to watch and view it on our tv.

My apologies for any mistakes, english is not my first language

I’m not sure how Windows libraries are linked in with file sharing (I didn’t think they were), but i’m guessing that you don’t have file sharing setup in Windows for the folders you want to share. You should find plenty of information on how to do that with a google search. OSMC works with standard Windows sharing (SMB) so there is no special configuration or extra software needed on the Windows side. Once you configured Windows and have that working you can either follow one of the guides you linked to above to mount those shares at an OS level, or alternatively just directly access the shares in Kodi by adding a source and manually entering in the address (smb://ip.of.yourpc/share_name/).

Windows libraries is how files appear on the Vero when I pick upnp option.

I have the file sharing setup in windows for the folders (drives to be more exact)
I have been following the guides, to no avail.

Entering IP gives nothing back.
Unless you’re telling me to individually share each folder.

Have you tried this troubleshooting from the fstab tutorial to verify your Windows 10 setup?

My guess is that it’s the SMB version problem you are running into. The above command will help narrow down the issue.

1 Like

Thank you, I will try it

Also try the smbclient command with a SMB version:

smbclient -m SMB3 -L ip.of.the.server -U my_username

You probably don’t want to use UPnP as you cannot add that type of source to a Kodi library.

Yes, you right click on the folders you want to share in windows and enable sharing for them. There is no default file shares setup in Windows just by turning file sharing on. If you open file explorer on your Windows machine and type in \\ip.of.your.pc in the address bar (note Windows uses backslash while Linux uses forward slash) you will be able to see any folders you are currently sharing in Windows.

Also in Kodi you will not be able to browse to find your file shares as that would require SMBv1 which is disabled by default. That is why I said you must manually enter the network path.

I tried the above, get the following error:
protocol negotiation failed: NT_STATUS_CONNECTION RESET

smbclient -m SMB3 -L ip.of.the.server -U my_username

I get some more…
Domain=[DESKTOP] OS= Server=

    Sharename       Type      Comment
    ---------       ----      -------
    ADMIN$          Disk      Remote Admin
    C$              Disk      Default share
    D               Disk
    D$              Disk      Default share
    E               Disk
    E$              Disk      Default share
    F               Disk
    F$              Disk      Default share
    IPC$            IPC       Remote IPC

Connection to ip.of.the.server failed (Error NT_STATUS_RESOURCE_NAME_NOT_FOUND)
NetBIOS over TCP disabled – no workgroup available

Windows no longer allows you to share an entire drive. You would have to make subfolders on the drives and share those folders.

Done did that
How do I access them/view them on the Vero?

Do your file shares show up in Windows explorer now using a UNC path as I outlined previously?


videos>files>add videos>browse>add network location>

Use SMB and preferably the IP address of your PC instead of a name (hopefully this is already set to use a static address), don’t try to browse, and don’t set a folder, but do add the user/pass of an account on your PC that has access to the files and share. Once you click OK you will then have your PC in the list of sources and you can browse that to add the individual source locations.

1 Like

Hello, thank you for the help, I can access drives fine now, by the way sharing whole drives work, I can enter them and add folders from within them.
I can’t seem to lot TV-shows as a seperate “option” though, although i select it. There is no TV show tab on main screen, the “get to know your box” quest continues!

Thank you again for your help

TV shows and movies must be in different folders and one must not be contained inside of a subfolder of the other. For each source you set the content type and choose the scraper you want to use. When you have added a TV show type source and have scrapped at least one episode the “TV Shows” category will automatically show up on the home screen. I would recommend reading over Kodi’s wiki on the subject…

1 Like

Will do, thank you very much again for your help.