Configuring composite output

Composite video can be configured by editing /etc/X11/xorg.conf.

You then run a cable from the Green connector on the ATV1 to your TV


Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    Option "RegistryDwords" "RMDisableRenderToSysmem=1"
    Option "DynamicTwinView" "false"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    Option         "UseDisplayDevice" "TV"
    Option         "DPI" "100x100"
    Option         "UseEvents" "1"
    Option         "AddARGBVisuals" "1"
    Option         "AddARGBGLXVisuals" "1"
    Option         "TVOutFormat" "COMPOSITE"
    Option         "TVStandard" "NTSC-M"
    Option         "TVOverScan" "0.80"
    DefaultDepth    24
    Option         "NoLogo" "True"
    Option         "Coolbits" "1"
 SubSection "Display"
 Depth 24
 Modes "720x480" "640x480"
 EndSubSection
EndSection

1 Like

this is my xorg.conf file for working COMPOSITE video output (connect the yellow connector to the green output in back of the ATV1)

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 340.46  (buildd@binet)  Tue Oct  7 08:03:22 UTC 2014
 
Section "ServerLayout"
    Identifier     "serverlayout0"
    Screen      0  "screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection
 
Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "keyboard"
EndSection
 
Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection
 
Section "Monitor"
    Identifier     "monitor0"
    VendorName     "SNY"
    ModelName      "Sony TV"
    Option         "DPMS"
EndSection
 
Section "Device"
    Identifier     "device0"
    Driver         "nvidia"
EndSection
 
Section "Screen"
    Identifier     "screen0"
    Device         "device0"
    Monitor        "monitor0"
 DefaultDepth 24
 Option "DPI" "100x100"
 Option "UseEvents" "1"
 Option "AddARGBVisuals" "1"
 Option "AddARGBGLXVisuals" "1"
 Option "UseDisplayDevice" "TV"
 Option "UseEDID" "FALSE"
 Option "TVOutFormat" "COMPOSITE"
 Option "TVStandard" "NTSC-M"
 Option "TVOverScan" "0.80
 Option "NoLogo" "True"
 Option "Coolbits" "1"
 SubSection "Display"
 Depth 24
 Modes "720x480" "640x480"
 EndSubSection
 
EndSection

I figured following these steps to enable composite output would be simple enough but I tried using Bitvise and WinSCP from Windows and despite having logged in, cant seem to do things.

I’ve done edits on a JBroken iPhone before

PS: I was wondering why this is not enabled by default?

https://osmc.tv/wiki/apple-tv/configuring-component-output/

user/pass is osmc/osmc

If using WinSCP you will want to install Notepad++ and make it the default WinSCP editor, also check this out Cannot get root access via WinSCP - #2 by Dilligaf

How do I create/ copy backup of it in the same folder before editing it?
PS: I have Notepad2 as default editor replacing Notepad and it can read linux files as well from what I know.

In WinSCP just right click on the file>Duplicate>Name the duplicate to foo.txt.bak or whatever

Hello,
Has anyone worked out how to adjust the Colour Space?

I’m on CRT TV using a YUV to RGB Scart Converter but sadly having to enter the TV in the second non-RGB Scart input.

The TV has true colours on the Virgin Media box through RGB Scart but ATV1 is producing too much RED on Composite video out.

Hi, It’s been awhile since I configured 2 of my ATV’s to composite and Component
and now want to configure another one.
I have logged in via locally, with PuTTy, and WinSCP.
Login is successful but when i enter " /etc/X11/xorg.conf "
I get "ACCESS DENIED "
It worked a year or two ago ? Any suggestions , please.
Thanks.

Did you use su?

When I use su /etc/X11/xorg.conf I get “no such file”

Same with sudo /etc/X11/xorg.conf.

Using /etc/X11/xorg.conf I get "Permission Denied "

I may have been mistaken with the "Access Denied " sorry.

sudo nano /etc/X11/xorg.conf

sudo nano got me in,
Thanks ActionA and all

By the way I don’t remember using those last time, did something
change or is it just my getting old(er) ?

Nothing changed but, I’m sure none of us are getting younger :wink: