Confused over settings to play 4K videos

Well, I’m confused a lot, so it’s not the fault of my Vero or Kodi :joy:.
Thing is, I’ve read here that I only need to have my video settings at 1080p and 60hz to play 4K movies.
But people have also said stuff about ‘refresh rate’ that I can’t find in my settings. I can’t remember specifics but I remember seeing the words “…stop\start”. Whereas my settings say “Delay after change of refresh rate” and the options are either ‘OFF’ (which mine is) or allow you to set a delay time.
Do I just leave this at OFF?
Cleo Puzzled

That’s a different setting, keep that off. Here are the settings concerned

Settings>System>Display>Resolution> 1920x1080p
Settings>System>Display>Whitelist> (empty) *
Settings>Player>Videos>Adjust display refresh rate> On start/stop

Some televisions may also need, or benefit from, the following being set…

System>Display>Force 4:2:2 colour subsampling> (enable)

With the above settings your UI will be output in Full HD and your 4K content will be output in 4K. *Information regarding the whitelist can be found here. If you have any doubt, feel free to upload some logs so we can verify that your settings are indeed correct.

Marvelous, fzinken! Thank you so much!
BTW, now you’ve mentioned ‘logs’, it’s reminded me that always, always, when I play a video, I have to hit the pause button at the beginning and turn on subtitles because the ‘default’ (is that right?) seems to be OFF. But I have no idea how to send you logs. Duh :roll_eyes:

Was indicated to you in this thread

I’m thick, soorry. How to turn on debug logging?

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Thank you :woozy_face:
I think even I can follow that.
Oh, and the 4K settings, they were all okay! I just tried a 4K movie and it looks great!

Okay, I think I have done the logging and uploading :innocent:
Is this the URL that you need?:
I hope the log is OK, I found I had to give it lots of time between each action, otherwise it just kept freezing, BRRRR :wink:
Thank you so much for checking this out for me.
Oh, did I need to say it’s to find out why I have to keep manually setting the srt files to ON?

In settings>player>videos disable sync playback to display.

In settings>player>language> change the language from “English (US)” to “English”

Many thanks fzinken and darwindesign - the subtitles work automatically! Wonderful!