Considering TCL 55P607

I think I was able to get all the keys on the remote working. As there are only arrow, ok, back a a few others that’s not many.

You might consider getting a Vizio. My replacement for the TCL was a Vizio 4K D series, and I’m very happy with that TV, and the CEC works fine on it.

@bmillham You are awesome mate! I actually REALLY like the simple remote (Actually, I guess Pause/Play are somewhat important too :slight_smile: )

The only reason I am NOT considering the Vizio is it’s lack of OTA ATSC TV Tuner.
My wife, being a baseball fan, requires this just for baseball broadcasts.

It depends on the Vizio, my D series does have an ATSC Tuner.

I don’t remember for sure if the Pause/Play worked.

1 Like

I just plugged an Hauppage 950Q tuner into my Vero the other day and had OTA ATSC up and running through Kodi in no time. For me, that’s already one less remote to worry about.

1 Like

I hadn’t thought of using a USB Ota tuner! What a splendid idea :slight_smile:

Does live TV work just like it would from a TV tuner? Channels up or down, via numbers, or possibly even pulling up a TV guide! - all via CEC on the osmc box?

Edit - Google Foo answers: Feedback on using OSMC: tuner, Program recording, antenna - #37 by Slartibartfast

Really lovely - this opens up a bunch of other options

I don’t use CEC so I can’t comment on that, but the TV/EPG works as well as any set top box with PVR support that Iv’e used in the past. I’m using the osmc remote, so no direct number input that I can find, but I’ve only got a handful of local channels anyway.

The EPG content off the air was a little spotty for me, so I set up a account and xmltv yesterday which seems to be working better. [Obsolete] How to populate EPG data with zap2xml - #3 by wbeard52

OTA on Kodi is new for me, so I’m still on the learning curve myself, but just having all my media sources through one device is already a much better TV experience.

1 Like

Awesome info!

The picture quality is fantastic… and the TV interface is the BEST I have ever used.

While CEC works on the TCL 55P607… it does not appear to work with OSMC… and i do not know what further steps to test… or if I can provide any information to @sam_nazarko & friends to see if CEC can be made to work with this TCL line. As I despise having multiple remotes, no CEC is a deal breaker for me and the TV will need to be returned within the 30 day window.

I have tried every HDMI port, a combination of all 4 CEC types, and even starting the tv directly into the OSMC source.

Settings > System > Control other devices (CEC)/Search for CEC devices shows KODI regardless of what HDMI source I hook it up to.

CEC types per the manual
1 - HDMI® ARC is the audio return channel that is available on one of the TV’s HDMI® ports. The audio return channel enables you to send a Dolby Audio™ signal back to a home theater receiver that is also sending an audio and video signal into the TV.
2 - System audio control enables the TV remote control to change the volume and mute state of an amplifier or sound bar connected through HDMI®, and to display the external device’s volume and mute status in the TV’s on-screen display.
3 - 1-touch play enables a component to control which TV input is active. For example, pressing Play on your Blu-ray™ player switches the TV to the Blu-ray™ input.
4 - 1-touch play enables a component to control which TV input is active. For example, pressing Play on your Blu-ray™ player switches the TV to the Blu-ray™ input.


Did you try other HDMI cables?

@fzinken I pulled off Vero with HDMI from Samsung TV, tried on tcl, moved to Sony at work. Only TV of the 3 that the cec didn’t function was the tcl (same PSU and HDMI cable)…

If we can get cec working, that would be lovely… Have 30 days to figure it out :slight_smile:

Hi Chris – how are you keeping?



Logs might give us some clues.
See Vero2 CEC error message - #6 by sam_nazarko. May help, but more info is needed.



Good day Sam! Long vision projects still coming along nicely?
I’m fairing rather well – my wife may say I’ve begun aging – as if in a salami gaining a delightful zing or tainting is yet to be decided.

Here is CEC working just fine on a Sony X690E

Swapped to the TCL 55P607 (only change is adding a usb wired keyboard). After all CEC functions tried with no reaction, used keyboard to upload log

Change device_type from 4 to 1 in /usr/share/kodi/system/peripherals.xml
No joy on cec after rebooting, unplugging all, refreshing cec on set, etc, so set it back to 4

Side note, work just picked up a TCL 55p607 so I have access to both it and the Sony. Even if we are out of luck, and I must return MY TCL, I can still do testing at the office if desired.

I’m not sure what CEC functions you expect to be provided by the TCL. The manual seems to indicate only very limited support. When you search for CEC devices in the TV settings, is the Vero even discovered there?

Yes, but I’m still rather short sighted.

Oh dear. The jokes will come next.

This is the first step indeed.
Stopping Kodi with sudo systemctl stop mediacenter and running cec-client may also provide some clues.


leave a bad taste or something

yes - as kodi

osmc@OSMC:~$ sudo systemctl stop mediacenter
osmc@OSMC:~$ cec-client
No device type given. Using 'recording device'
CEC Parser created - libCEC version 4.0.2
no serial port given. trying autodetect:
 path:     /dev/AmlogicCEC
 com port: Amlogic

opening a connection to the CEC adapter...
DEBUG:   [              71]     Broadcast (F): osd name set to 'Broadcast'
NOTICE:  [              72]     connection opened
DEBUG:   [              73]     processor thread started
DEBUG:   [              73]     << Broadcast (F) -> TV (0): POLL
TRAFFIC: [              74]     << f0
DEBUG:   [             105]     >> POLL sent
DEBUG:   [             105]     TV (0): device status changed into 'present'
DEBUG:   [             105]     << requesting vendor ID of 'TV' (0)
TRAFFIC: [             105]     << f0:8c
TRAFFIC: [             289]     >> 0f:00:8c:04
DEBUG:   [             289]     marking opcode 'give device vendor id' as unsupported feature for device 'TV'
DEBUG:   [             289]     >> TV (0) -> Broadcast (F): feature abort ( 0)
DEBUG:   [             289]     expected response received (87: device vendor id)
NOTICE:  [             289]     registering new CEC client - v4.0.2
DEBUG:   [             289]     detecting logical address for type 'recording device'
DEBUG:   [             289]     trying logical address 'Recorder 1'
DEBUG:   [             289]     << Recorder 1 (1) -> Recorder 1 (1): POLL
TRAFFIC: [             289]     << 11
WARNING: [             466]     Write: write failed
TRAFFIC: [             466]     << 11
WARNING: [             644]     Write: write failed
DEBUG:   [             644]     >> POLL not sent
DEBUG:   [             644]     using logical address 'Recorder 1'
DEBUG:   [             644]     Recorder 1 (1): device status changed into 'handled by libCEC'
DEBUG:   [             644]     Recorder 1 (1): power status changed from 'unknown' to 'on'
DEBUG:   [             644]     Recorder 1 (1): vendor = Pulse Eight (001582)
DEBUG:   [             644]     Recorder 1 (1): CEC version 1.4
DEBUG:   [             644]     AllocateLogicalAddresses - device '0', type 'recording device', LA '1'
DEBUG:   [             644]     Recorder 1 (1): osd name set to 'CECTester'
DEBUG:   [             644]     Recorder 1 (1): menu language set to 'eng'
DEBUG:   [             644]     AutodetectPhysicalAddress - autodetected physical address '2000'
DEBUG:   [             644]     Recorder 1 (1): physical address changed from ffff to 2000
DEBUG:   [             644]     << Recorder 1 (1) -> broadcast (F): physical address 2000
TRAFFIC: [             644]     << 1f:84:20:00:01
NOTICE:  [             784]     CEC client registered: libCEC version = 4.0.2, client version = 4.0.2, firmware version = 0, logical address(es) = Recorder 1 (1) , physical address:,  compiled on Sat May 27 17:20:30 UTC 2017 by root@compiler2 on Linux 3.16.0-4-amd64 (armv7l), features: P8_USB, DRM, P8_detect, Amlogic
DEBUG:   [             784]     << Recorder 1 (1) -> TV (0): OSD name 'CECTester'
TRAFFIC: [             785]     << 10:47:43:45:43:54:65:73:74:65:72
DEBUG:   [            1069]     << requesting power status of 'TV' (0)
TRAFFIC: [            1070]     << 10:8f
TRAFFIC: [            1265]     >> 01:46
DEBUG:   [            1265]     << Recorder 1 (1) -> TV (0): OSD name 'CECTester'
DEBUG:   [            1265]     >> TV (0) -> Recorder 1 (1): give osd name (46)
TRAFFIC: [            1265]     << 10:47:43:45:43:54:65:73:74:65:72
TRAFFIC: [            1641]     >> 01:90:00
DEBUG:   [            1642]     >> TV (0) -> Recorder 1 (1): report power status (90)
DEBUG:   [            1642]     TV (0): power status changed from 'unknown' to 'on'
DEBUG:   [            1642]     expected response received (90: report power status)
waiting for input

That is my fear… that the manual is actually reporting correctly. Rare breed would that be… but plausible i suppose.

thanks for taking a peek folks

I did warn you that my TCL had limited CEC support :stuck_out_tongue:

1 Like

what do you folks think of adding a page to the wiki

CEC Known Compatible Devices
Vendor, Model, Device_type 1/4, CEC (Full, No, Partial), Date confirmed, Notes

Sony, X690E, 4, Full, 2017/11/20, NA
TCL, 55p607, 4, No, 2017/11/20, Recognized by TV but no CEC controls passed to OSMC
Samsung, LN46A650, 4, Full, 2017/11/20, NA
Samsung, LN40A750, 4, Full, 2017/11/20, it takes about 30 seconds for CEC to begin functioning after a cold boot
Vizio, 4K D 2017, ?, Full, 2017/11/20, NA.

edit CEC Known Compatible Devices

I think it’s easier to list problematic sets than all sets, if that makes sense



Quote from review site rtings

With CEC enabled, HDMI devices do turn off when the TV is turned off, but the TV’s remote can’t be used to navigate the menu of our PlayStation 3 or Samsung UHD Blu-ray player, which is possible on many other TVs with CEC.

Ahh bummer. Back in the crate

1 Like