Could not connect to Wi-Fi

What version of OSMC are you using? i expect RC3
Have you installed all the updates released AFTER RC3 (you need to do that with a lan cable)?
After RC3 (you can fine tons of topics relating this issues) no one was able to connect to wifi (“connection failed”), until a couple of fixes by the dev team.

No, I’m using 2015.06-1
All updates are checked and installed
Should I try RC3 version?

I dont understand what’s the problem, but the adapter worked for one time after those manipulations:

Update through terminal(apt-get update and upgrade)
Reboot
Update through OSMC own updater
Reboot
Gone to Wireless and reenabled the adapter
**
After that it connected automatically and worked untill the end of session
After that I rebooted, and it didn’t work again(it fails to connect after typing password). Reenabling is not helping now

Hi!

On my Pi 1 model B I have a problem with the wifi failing to connect on a network which is password protected. It works fine if there is no encryption (open network). (I typed my pw correctly, tried at least 20 times and even with a password with only lowercase letters and no fancy characters).

I have the same wifi dongle on an other Pi (with Volumio) and it works perfectly with the password protected network.

So it seems there is a problem with osmc trying to connect to a wpa/wpa2 personal wifi.

Any idea?

Thank’s

Oliver

@Marky is that the same problem configuration as yours?

Rpi 1 model B with osmc fully updated up to july the 2nd.

Edit: the same happens after a clean install with new stable release.

I’ve got a RPi 2 model b with OSMC ver. 2015.06-1. Last checked updates today.


@oliver1 I face absolutely the same problem using OPENELEC, so the problem is in the Kodi core.

@Marky

@oliver1

Can you both try connecting to wireless using the command line tool connmanctl. This will rule out (or implicate) the networking GUI.

To do so you’ll either need to temporarily connect Ethernet and run the command via an SSH session, or plug in a Keyboard and exit Kodi to log in at a local console session:

https://osmc.tv/help/wiki/console

Once you’re logged into a command prompt the following demonstrates enabling wifi, scanning for networks and connecting to an authenticated network:

osmc@rpi2:~$ connmanctl

connmanctl> enable wifi
Enabled wifi

connmanctl> scan wifi
Scan completed for wifi

connmanctl> services
*AO Wired                ethernet_b827ebd04564_cable
                         wifi_e894f6191023_hidden_managed_psk
    VM420130-2G          wifi_e894f6191023_564d1235f53035302d3247_managed_psk

connmanctl> agent on
Agent registered

connmanctl> connect wifi_e894f6191023_564d1235f53035302d3247_managed_psk

Agent RequestInput wifi_e894f6191023_564d1235f53035302d3247_managed_psk
  Passphrase = [ Type=psk, Requirement=mandatory, Alternates=[ WPS ] ]
  WPS = [ Type=wpspin, Requirement=alternate ]
Passphrase? xxxxxxxx

Connected wifi_e894f6191023_564d1235f53035302d3247_managed_psk

connmanctl> services
*AO Wired                ethernet_b827ebd04564_cable
*AR VM420130-2G          wifi_e894f6191023_564d1235f53035302d3247_managed_psk
                         wifi_e894f6191023_hidden_managed_psk

Let us know whether you are able to connect this way or not.

(BTW connmanctl has a very useful help command)

1 Like

Can’t be - Kodi itself has nothing to do with setting up wifi connections.

One thing OSMC and OpenElec share in common is using connman as the network manager which handles wireless connections. Raspbian does not use connman. There could potentially be an issue in connman - the above test with connmanctl may shed some more light.

Ok, will try in a few minutes

@DBMandrake

root@osmc:/home/osmc# connmanctl
connmanctl> connect wifi_0013efc5093b_4d61726b79_managed_psk
Error /net/connman/service/wifi_0013efc5093b_4d61726b79_managed_psk: Input/output error
connmanctl> connect wifi_0013efc5093b_4d61726b79_managed_psk
Error /net/connman/service/wifi_0013efc5093b_4d61726b79_managed_psk: Input/output error
connmanctl> enable wifi
Error wifi: Already enabled
connmanctl> scan wifi
Scan completed for wifi
connmanctl> services
*AO Wired ethernet_b827eb570082_cable
*A Marky wifi_0013efc5093b_4d61726b79_managed_psk
Vika wifi_0013efc5093b_56696b61_managed_psk
Sasha wifi_0013efc5093b_5361736861_managed_psk
Sherwood wifi_0013efc5093b_53686572776f6f64_managed_psk
connmanctl> agent on
Agent registered
connmanctl> connect wifi_0013efc5093b_4d61726b79_managed_psk
Agent ReportError wifi_0013efc5093b_4d61726b79_managed_psk
connect-failed
connmanctl> Retry (yes/no)? y
Agent ReportError wifi_0013efc5093b_4d61726b79_managed_psk
connect-failed
connmanctl> Retry (yes/no)? y
Connected wifi_0013efc5093b_4d61726b79_managed_psk


It seems that it worked on the third try.

Before you reboot after this session of manually connecting, can you capture the system journal ?

sudo journalctl | paste-log

The fact that it took 3 attempts to connect even using connmanctl immediately rules out a bug in the Networking GUI in OSMC settings.

If you’re absolutely sure that Raspbian connects reliably every time on the same Pi with the same wireless adaptor in the same location then it narrows the problem down to either the kernel driver for the wifi adaptor, a bug in connman or a problem with the wpa supplicant.

Unfortunately, I rebooted the system untill you asked to post logs
Manual connecting is not working this time

connmanctl> agent on
Agent registered
connmanctl> connect wifi_0013efc5093b_4d61726b79_managed_psk
Agent ReportError wifi_0013efc5093b_4d61726b79_managed_psk
connect-failed
connmanctl> Retry (yes/no)? y
Agent ReportError wifi_0013efc5093b_4d61726b79_managed_psk
connect-failed
connmanctl> Retry (yes/no)? y
Agent ReportError wifi_0013efc5093b_4d61726b79_managed_psk
connect-failed
connmanctl> Retry (yes/no)? y
Agent ReportError wifi_0013efc5093b_4d61726b79_managed_psk
connect-failed
connmanctl> Retry (yes/no)? y
Agent ReportError wifi_0013efc5093b_4d61726b79_managed_psk
connect-failed
connmanctl> Retry (yes/no)? y
Agent ReportError wifi_0013efc5093b_4d61726b79_managed_psk
connect-failed
connmanctl> Retry (yes/no)? y
Agent ReportError wifi_0013efc5093b_4d61726b79_managed_psk
connect-failed
connmanctl> Retry (yes/no)? y
Agent ReportError wifi_0013efc5093b_4d61726b79_managed_psk
connect-failed
connmanctl> Retry (yes/no)? y
Agent ReportError wifi_0013efc5093b_4d61726b79_managed_psk
connect-failed


Last logs: http://paste.osmc.io/ezehitujut

kodi.old.log found on CD Card: http://paste.osmc.io/eyocoladeb.vhdl

What wifi channel is your AP/wifi work at, is it set to automatic? or a fixed channel?..

some of the higher channels have trouble with microwave ovens and other thing like a refrigerator, close to ,bad antenna cable/TV… check to see if your AP/wifi is on automatic channel.

The channels on my router are set to automatic

Which is generally not a good idea, as routers can be very poor at picking a channel to use. In theory they should scan for other AP’s and try to avoid those channels but more often than not this is not the case. Also a bunch of nearby routers all set to auto can end up with them playing musical chairs because each is looking for a channel that others are not using - so you end up on a different channel each time you turn on your router.

I would install a wifi scanner such as inSSIDer on a laptop and scan to see what channels are being used by neighbours, and try manually picking channel 1, 6 or 11 based on which ones have the least stations and/or weakest signals from neighbours…

You also haven’t mentioned how far the Pi is from the router ?

My router is 2 metres far from the router, and it has a good signal.


I will try to change the channel and tell you if it connected in a couple of minutes

As you can see, there is no networks on 10th channel, I will set it static, or set 11?

i would set it on a low channel, like 2.

marky@Marky-UB:~$ ssh ‘osmc@192.168.1.101’
ssh: connect to host 192.168.1.101 port 22: Network is unreachable
marky@Marky-UB:~$ ssh ‘osmc@192.168.1.101’
The authenticity of host ‘192.168.1.101 (192.168.1.101)’ can’t be established.
ECDSA key fingerprint is 3c:5e:3c:81:0c:83:d7:f1:5d:a2:cf:d6:46:2b:97:71.
Are you sure you want to continue connecting (yes/no)? y
Please type ‘yes’ or ‘no’: yes
Warning: Permanently added ‘192.168.1.101’ (ECDSA) to the list of known hosts.
OSMC: Open Source Media Center

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Thu Jul 2 17:58:13 2015 from 192.168.1.104
osmc@osmc:~$ sudo shutdown -r now
Connection to 192.168.1.101 closed by remote host.
Connection to 192.168.1.101 closed.
marky@Marky-UB:~$ ssh ‘osmc@192.168.1.101’
OSMC: Open Source Media Center

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Fri Jul 3 08:16:49 2015 from 192.168.1.104
osmc@osmc:~$ connmanctl
connmanctl> enable wifi
Error wifi: Already enabled
connmanctl> scan wifi
Scan completed for wifi
connmanctl> services
*AO Wired ethernet_b827eb570082_cable
*A Marky wifi_0013efc5093b_4d61726b79_managed_psk
Sherwood wifi_0013efc5093b_53686572776f6f64_managed_psk
Sasha wifi_0013efc5093b_5361736861_managed_psk
Vika wifi_0013efc5093b_56696b61_managed_psk
connmanctl> agent on
Agent registered
connmanctl> connect wifi_0013efc5093b_4d61726b79_managed_psk
Agent ReportError wifi_0013efc5093b_4d61726b79_managed_psk
connect-failed
connmanctl> Retry (yes/no)? y
Agent ReportError wifi_0013efc5093b_4d61726b79_managed_psk
connect-failed
connmanctl> Retry (yes/no)? y
Agent ReportError wifi_0013efc5093b_4d61726b79_managed_psk
connect-failed
connmanctl> Retry (yes/no)? y
Agent ReportError wifi_0013efc5093b_4d61726b79_managed_psk
connect-failed
connmanctl> Retry (yes/no)? y
Agent ReportError wifi_0013efc5093b_4d61726b79_managed_psk
connect-failed
connmanctl> Retry (yes/no)? y
Agent ReportError wifi_0013efc5093b_4d61726b79_managed_psk
connect-failed
connmanctl> Retry (yes/no)? y
Agent ReportError wifi_0013efc5093b_4d61726b79_managed_psk
connect-failed
connmanctl> Retry (yes/no)? y
Agent ReportError wifi_0013efc5093b_4d61726b79_managed_psk
connect-failed
connmanctl> Retry (yes/no)? y
Agent ReportError wifi_0013efc5093b_4d61726b79_managed_psk
connect-failed
connmanctl> Retry (yes/no)? y
Agent ReportError wifi_0013efc5093b_4d61726b79_managed_psk
connect-failed
connmanctl> Retry (yes/no)? n
Error /net/connman/service/wifi_0013efc5093b_4d61726b79_managed_psk: Input/output error


Set the 2nd channel, but nothing changed. Logs: http://paste.osmc.io/ubigewozag

Sorry but I don’t have any other ideas or suggestions for you at this time - other than to try a different model of wireless adaptor as a test. It may be that there is an issue with the driver that supports that wireless adaptor.

Without trying a completely different adaptor (which uses a different driver) it’s not really possible to know whether it’s a driver bug or an environmental factor such as the configuration of your network, interference and so on.