Cron not working after reinstall

See first post

Cheers, missed that.

  1. So what exactly is the current problem?

  2. I did notice you’re using an ampersand on the first line. That’s not necessary, since cron jobs are automatically run in the background.


happy reading you seem to need it never seen commands performed like that, if you feel insecure about cron still

and if this all about getting Sickrage to run, then use this thread

I’m sorry if this comes out harsh but there seems to be a lot of confusion in this thread.

Have you even read the posts in this thread? Please point to what’s strange in my crontab -e

Posting a link to a wiki isn’t very helpful

Posting instructions on how to install Sickrage, when I have a working Sickbeard setup isn’t very helpful either.

Problem is cron isn’t starting sickbeard @reboot, the first line in crontab -e that is

Everything else is running now it seems. I’ll try removing the ampersand and see if that makes a difference. As I’ve mentioned earlier, this crontab -e is just a copy-paste from the previously working configuration, that’s why I didn’t want to edit it, because I know it has been working for over a year

Threads this long have a tendency to lose focus. At least I know where to look now.

Thanks, I’ll try and keep that in mind, so I’ve removed the ampersand and now I do get an entry in the log:

Traceback (most recent call last):
  File "/home/osmc/SickBeard/", line 36, in <module>
    from multiprocessing import freeze_support  # @UnresolvedImport
  File "/usr/lib/python2.7/multiprocessing/", line 64, in <module>
    from multiprocessing.process import Process, current_process, active_children
  File "/usr/lib/python2.7/multiprocessing/", line 312, in <module>
    _current_process = _MainProcess()
  File "/usr/lib/python2.7/multiprocessing/", line 309, in __init__
    self._authkey = AuthenticationString(os.urandom(32))
NotImplementedError: /dev/urandom (or equivalent) not found

Keep in mind, sickbeard is working if I simply start it manually

Debugging SickBeard is a little beyonf the remit of this forum, but I’ll make an educated guess that cron is starting it too early.

If correct, you have a couple of options:

Place your startup command in a wrapper script, that does something along the lines of:

while I can't ping google
  sleep 10
run Sickbeard

but that’s pretty hacky, IMO.

Since you want it to run at startup, I’d recommend you create a systemd .service file and enable it to run at startup. Here’s a thread about getting SickRage to run at startup:

since they’re related, it should be a good starting point.

Thanks, didn’t think of that. I should be able to try@reboot sleep 60 && run/SB to see if that’s what’s causing the problem?

he doesnt have to create the file its included in the git

all he have to do is modify the paths for it then move it and enable it

He’s using SickBeard, but I guess there’s also a systemd .service file for that.

The only thing to note is that in the thread I linked to, at least for SickRage, the .service file needed one extra line before it would run successfully in OSMC.

Thanks for pointing out that SB probably started too soon. I tried adding a 60 second delay to crontab as this was the fastest way to determine if that was the problem. Now SB starts at reboot.

I’ll probably replace it with a proper startup script later.

Thank again