Deluge for OSMC?


any plans to implement deluge in OSMC? Need to decide whether to take a limited time offer for fixed line internet and that would be the main criterium …

cheers and keep up the good work

It’s linux, even if it wasn’t included, deluge, transmission, or any number of torrent clients could be used.

Yes, it’s in the app store

thx everybody!

@sam_nazarko I do not see it in the app store, started using OSMC recently, any pointers on how to install deluge?

You can simple install it using

sudo apt-get install deluge

I suggest to use the WebUI as well:

sudo apt-get install deluge-web

Depending on the version available in the repository, you can always compile it yourself, it takes just a few minutes:

sudo apt-get install python python-twisted python-twisted-web python-openssl \
python-simplejson python-setuptools intltool python-xdg python-chardet \
geoip-database python-libtorrent python-notify python-pygame python-glade2 \
librsvg2-common xdg-utils python-mako bzip2 -y

cd ~/
mkdir deluge
cd deluge
tar xvf deluge-1.3.11.tar.bz2
cd deluge-1.3.11
python clean -a #may look like error message, is not, nothing to worry$
python build
sudo python install
sudo python install_data
cd ~/
sudo rm -rf deluge/

after it finishes, start deluge with


give it a few seconds, stop it:

sudo pkill deluged

the above is needed to generate the initial config file, which we will modify to grant access to the osmc user:

cp ~/.config/deluge/auth ~/.config/deluge/auth.old
nano ~/.config/deluge/auth

add the line:


at the end of the file and save with ctrl+x

to allow remote access, run also these commands:

config -s allow_remote True
config allow_remote

with deluge already runing, to start the web interface in the background run:

deluge-web --fork

at any point you can kill all with

sudo pkill deluge

The instructions above were 99% inspired from the website, I only added bzip2 in the initial install, bumped the version to 1.3.11 and changed the user from pi to osmc.

I hope it helps.


Great HowTo, just one point:

cp ~/.config/deluge/auth ~/.config/deluge/auth.old
nano ~/.config/deluge/auth</code>

The </code> at the end of the second line is wrong.

Thanks, forgot to remove that one when switching to idents.

1 Like

Thanks for a great guide.
I have a simple follow-up question.

How do i get “deluged” and “deluged-web --fork”
to autostart on my RPi2/OSMC bootup?

You should be able to use the Ubuntu Initd script:

The setting up of this script is also covered here:

I’ve tested it once, but didnt had any success (but didnt looked for possible error and gave up instead).

I’m using cron to auto-start the daemon. I’m not using the web-gui.

osmc@osmc:~$ crontab -e
@reboot /usr/bin/python /usr/local/bin/deluged

Supposedly a blank line at the end of crontab is important.

does not start, is this valid anymore?

Doesnt start up man is this valid?

deluge-web --fork

man how do i get the web gui to autostart because it doesn’t start on its own.

config -s allow_remote True
config allow_remote

also the above command gives key invalid on allow_remote

Have you tried putting a line like this in your crontab?

@reboot /usr/bin/python /usr/local/bin/deluge-web --fork

Like I said, I prefer to access deluge with the gui on my laptop versus a webpage, so I’ve not tried it.

Thanks will give it a try :smile:

the web ui uses deluge - so you may want

@reboot /usr/bin/python /usr/local/bin/deluge-web --fork 

in your crontab instead (--fork is what exits the process so other things can happen)

you can start the daemon from the webservice manually, but I’ve included both deluge-web and deluged (in that order) to start on reboot in my pi’s config

I also use ps aux | grep '[d]eluge' to check if both the web ui and the daemon are running.


How do i autostart deluged on startup?

I use noth this lines on crontab, one for web and another for desktop version and none of it work

@reboot /usr/bin/python /usr/local/bin/deluged
@reboot /usr/bin/python /usr/local/bin/deluge-web --fork


follow this guide post install…delete init scripts and use systemd :wink: