[Deprecated] [TESTING] Bluetooth audio streaming (A2DP)

Any new when using hifiberry?

1 Like

Hi there.

The fix that went into the May update fixes issues where connectivity would drop almost immediately when pairing an audio device. Previously, it would pair up only to immediately disconnect. This fixes that issue.

In regards to the issue you’re experiencing - the internal bluetooth still seems to be stuttering regularly and i imagine this will be fixed in a future update (bluez) but at the moment the only way i’ve found to get around this is to use a USB bluetooth adapter.

Is there any ideas on when the Pi3’s bluetooth can be used for a2dp streaming? I’ve followed the instructions for install, and even edited the /boot/config.txt, but I still get no sound whilst trying to stream from my phone to OSMC.

on another note, it may be beneficial to include that it doesnt work currently with Pi3’s BT currently, I wasted a good few hours trying to get it to work :slight_smile:

AFAIK there is no difference between Pi3 Bluetooth and any other.

I’ve tried multiple times from fresh installs, just get no sound at all, connectivity seems to be okay.

take alook at this post, and a few afterwards:

EDIT: Just realised it was yourself who replied to this. Is there a changelog of this function anywhere, so i can tell if its been updated since the post above was made?

Added support for Raspberry Pi 3’s internal Bluetooth adapter. This is particularly useful as we are developing streaming capabilities for OSMC.

The Pi3 build in Bluetooth is supported since the April Update. And supports the same functions that are described at the top of this testing thread. No other functions have been implemented.

Thanks, I wasn’t totally convinced that this was my issue, as my bluetooth would connect fine. The issue seems to be my sample rate, which seems excessive:

May 07 15:08:40 osmc pulseaudio[257]: W: [pulseaudio] module-loopback.c: Sample rates too different, not adjusting (44100 vs. 462613).
May 07 15:08:40 osmc pulseaudio[257]: W: [pulseaudio] module-loopback.c: Sample rates too different, not adjusting (44100 vs. 462613).

Pulseaudio can only handle <192k, but it seems highly unlikely my S6 edge+ is outputting at such high sample rates, even on low quality youtube videos

EDIT:
I’ve noticed that the sample rate actually “increases” until it reaches 462624, I can’t find out why this is at all!

Hi,

i’m using a RPi 3 running OSMC May 2016 2016.05-1.

I’m also using a Logitech Bluetooth Audio Adapter (this one).
Pairing/Trusting and Playback worked pretty much out of the box.

I just had to turn on Bluetooth and set audio output to “ALSA: OSMC streaming to Bluetooth speaker / headphones”.
Playback works without stuttering or anything.
Even synchronisation issues/audio delay is barely noticeable.

But there’s a problem. After a while (i mean a pretty random amount of
time ranging from just a few seconds to > 1h) audio playback suddenly stops
with the following error message:

ERROR: CDVDAudio::AddPacketsRenderer - timeout adding data to renderer

After rebooting the RPi, bluetooth would reconnect and playback is fine until the next time this error comes up.

A truncated log (with audio debug) can be found here:

the video i was playing was already running for a while, maybe 10
min, there was some visible stuttering (no sound stuttering) at 19:07
(line 2 to 9 in the log)
the sound went off at 19:10 (line 18)

another non truncated log from another instance of the same error:
http://paste.osmc.io/osicerupoq
with the error coming up at
20:08:27 35.352921 T:1411888112

NOTE:
i’m using a hdmi to vga adapter if that matters at all… (“VicTsing®Gold-plated HDMI to VGA Converter Adapter For PC”, i can’t post link because of forum restrictions)

I was using ethernet port (with wifi access point), and BT dongle on RPI2. Then I swapped for RPI3. Nice overall performance improvement. Wifi seems to work ok - about the same as the Wifi access point which worked well.

Onboard BT I managed to get working. But the audio kept dropping out, and I would have to power-down and start again (i.e. pair, connect, set audio output). Often I would have to set audio to HDMI, then reboot, and then set audio back to BT streaming.

After a while I disabled onboard BT, and put back in my BT dongle.
This seems to be working better. It’s not dropping-out.

Note: this is in a home-brew media centre, and the RPI3 is behind
the screen. The range of the onboard BT might not be quite as good as the dongle. At one stage I left my BT speaker very close (about 1 meter away), but still I got fed up having to restart everything every so often.

Thanks.
Best regards,
Niall.

hi anbodearg

How do you disable the onboard bluetooth on rpi3?

Thanks

add a line in config.txt

dtoverlay=pi3-disable-bt

cheers :relaxed:

actually it took a few reboots, and also I removed the BT dongle, and re-inserted into the other USB port.

I was using a 5V2A power brick, and getting the occasional ‘rainbow box’ in the top right hand corner. So, I’m going to try with an official RPI 2.5A power supply and see if that was the cause of the problem with the onboard BT.

1 Like

@anbodearg
I tried different power supply and I still have the same issue as you.
Can you update your post or post a new answer if there is an improvement with a dedicated 2.5A power supply?

This sound dropping is driving me crazy and the quality of the analogue interface is not the best with my Bluetooth speaker.

Btw what dongle were you using ?

My BT dongle is the ModMyPi BLE4 dongle.
My BT speaker is Bose Soundlink Mini.

When it all works, it’s great, and the sound is very good.

I have it running 24/7, and this morning when I turned
on BT speaker … everything was working still
from yesterday.

I’ll report back when I upgrade power supply. I’m getting
the occasional rainbow - so I reckon power needs to be
resolved first.

Thanks for the information about the BT dongle.
I confirm with the CSR8510 it works flawlessly.

Which means the raspberry pi 3 has a problem with the onboard Bluetooth when used with the a2dp implementation.

@sam_nazarko Is it the good place to fill in a bug report about this ?

Yes: I’ve given up on the on-board BT for now.
The dongle works very well, though it would be nicer not to need it.

Most mornings I have to go through this:
(except yesterday morning, when everything just worked)

  1. reboot
  2. re-connect BT (it stays paired, but doesn’t always connect on boot up)
  3. change audio from BT streaming to e.g. HDMI
  4. change audio output back to BT streaming
  5. sometimes back to step 1.

Note: sometimes rainbow appears (very briefly) during step 3, and step 4.
So, I will try with official 5V2.5A p/s for RPI3, and I’ll report back.

Thanks.
Best regards,
Niall.

1 Like

Nice video anbodearg, that Bose Soundlink Mini sounds good where did you have it placed in video there?

I had no luck with on-board BT just tried dongle with my soundbar and its working good. :relaxed:

I notice that the audio is out of sync by second or so maybe its because im using v17 krypton test builds. Looks promising so far.

I read that the raspberry pi have put an update to the onboard BT so maybe this will help with this when sam updates it.

Im using the official 2.5a power supply and have had no issues with the rainbow icon.

@sam_nazarko I’m testing this feature on a seperate system as i want to keep my main system as stable as possible so is there a safe way to unistall this bluetooth a2dp testing if i decide to try it on my main system or should i stick with the testing system. I suppose i could just make a clone of my system onto another micro sd incase anything goes wrong. Thanks for your work OSMC is getting better everyday :relaxed:

There’s not a 100% clean way of uninstalling that I can recommend to users.

When it reaches the App Store, there will be.

I can confirm that. Using a separate dongle (CSL Nano) and deactivating the onboard btchip solved it for me.