[Deprecated] [TESTING] Bluetooth audio streaming (A2DP)

bluetoothctl connect 08:DF:1F:21:CB:03

Would you put this as the last line in /etc/rc.local …?
(I don’t see a ‘crontab’ for root)


Hmm, you’re right, it doesn’t seem to work. It does with connmanctl which bluetoothctl is modelled after. Odd.

Check the wiki

Cron is not working. Why?

OSMC ships without cron by default for performance reasons. Cron can be installed via the App Store.

But as replied, you would need to use pipe the connect command to bluetoothctl and also change the device accordingly.

ok, thanks … I guess putting in /etc/rc.local would work too?

Hello DBMandrake,

After upgrade my system with apt-get upgrade. I could not discovery bluetooth device anymore.

osmc@osmc:~$ uname -a
Linux osmc 4.2.3-3-osmc #1 PREEMPT Tue Oct 13 17:58:31 UTC 2015 armv6l GNU/Linux

What could you suggest me do?


I’ve tried to pair my phone with osmc under command line bluetoothctl:

[bluetooth]# scan on
[bluetooth]# pair 94:E9:6A:8C:93:59
[bluetooth]# trust 94:E9:6A:8C:93:59
[bluetooth]# connect 94:E9:6A:8C:93:59

after that I could see on my iphone and osmc the both were connected successfully.

But If I play the music I still could not found the option of streaming to OSMC in control center :frowning:

Hi Sam,

you recommend to update via My OSMC or it is still the same if we do it with

sudo apt-get update && sudo apt-get dist-upgrade

from the command line?


It’s the same. There’s unlikely to be any reason this would ever change but if it did, we would make huge announcements of it.

Hi DBMandrake,

This afternoon I’ve powered off and then power on my raspberry pi a few times and found the bluetooth audio streaming works! A bit progress for me.

But the sound goes to HDMI to my TV. Even though I’ve configured in OSMC the Audio output to “pi analog”.

if I stream audio via airplay, then everything works fine (sounds goes to the analog jack output).

Is there any special configuration for Bluetooth audio streaming? How could I force the audio output to analog jack?


I had bluetooth configured accroding to http://www.instructables.com/id/Enhance-your-Raspberry-Pi-media-center-with-Blueto/?ALLSTEPS. A2DP was working but I was loosing sound from time to time. I found this thread and installed app

wget http://paste.osmc.io/raw/qiyekuvafe -O- | sudo sh

And now I can’t connect. When I try from my phone it connects for a while and disconnects. When I try to connect from osmc using bluetoothctl I get

Attempting to connect to BC:CF:CC:2D:DD:07
Failed to connect: org.bluez.Error.Failed

Any idea why?

You should update from My OSMC. My OSMC will clean up unnecessary kernel packages on your system, but a dist-upgrade without autoremove does not.

By AirPlay, do you mean BT streaming from a phone to OSMC? The audio settings in Kodi won’t impact this, and you’ll probably need to use alsamixer to change your default output.

I would not recommend mixing the above tutorial and this application. This OSMC method will become the officially supported method in time, so you may wish to start fresh with this.


1 Like

Every here is working fine!!!
Thanks a lot for your hard work to get bluetooth headphones working with rpi+kodi

Just a note: when the pulse+bluetooth output is selected and my headphones are turned off, the sound on my tv is slightly slower than when the PI:HDMI output is selected.
Is this normal? anybody with the same issue?


I have instaled the package and I have tried it. My dongle was buyed at Aliexpress, a Cambridge Silicon Radio. It has been paired successfully with my phone and reproduced music from Spotify, but the sound is played after 30 or 40 seconds, and discontinued. It would be a problem with my dongle?

Probably yes – I experienced a similar problem with one of the dongles I had.

Thank you for your quick response , Sam , I think it was a problem of phone settings. Until now
I managed to get a continuous sound through hdmi , uncut and fluid, but now I want to get the sound output through the analog output . I changed to HDMI and analog , but I only get sound through hdmi , what can be the problem ?

Wow I completely missed this topic! This is what I wanted for so long! I am definitely going to test tomorrow and donate to you Sam!
So this is streaming to OSMC right? It’s perfect… exactly what lot’s of people wanted. Some might not even understand the power of this feature yet!

1 Like

To, and from. From OSMC to other devices will be problematic on some platforms (AppleTV, Vero) for now. But that’s why we have [TESTING] as the prefix.


1 Like

It is very strange, system sounds are played by the two ways, hdmi and analog, but when I send music from my phone via bluetooth, I just listen via hdmi …
What could be the problem?

You will need to configure the sink with alsamixer, not Kodi.


Can somebody explain me, how can i switch the output to analog or analog and hdmi?